Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1023 - RFC 868 time requests using UDP fail
Summary: RFC 868 time requests using UDP fail
Keywords:
Status: CLOSED DUPLICATE of bug 891
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netkit-base
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-02 02:57 UTC by Peter Greenwood
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-02-02 14:35:59 UTC


Attachments (Terms of Use)

Description Peter Greenwood 1999-02-02 02:57:05 UTC
UDP time requests to RH Linux systems (including 4.2, 5.0
and 5.1) fail. The symptoms are that no time is returned and
inetd reports "time/udp server failing (looping), service
terminated".

This turns out to be due to an error in inetd.conf.  The
time daemon in.timed is not suitable for handling udp
requests; however inetd provides an internal handler.
Therefore replacing the line:
time   dgram   udp     wait    nobody  /usr/sbin/tcpd
in.timed
with:
time    dgram   udp     wait    root    internal

gives the correct behaviour.

Peter

Comment 1 Aleksey Nogin 1999-02-02 06:49:59 UTC
This is a duplicate of the report #891

Comment 2 Jeff Johnson 1999-02-02 14:35:59 UTC
*** This bug has been marked as a duplicate of 891 ***


Note You need to log in before you can comment on or make changes to this bug.