Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1022505 - rhevm-log-collector hangs when running ausearch command from sos selinux plugin
Summary: rhevm-log-collector hangs when running ausearch command from sos selinux plugin
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector
Version: 3.2.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: 3.2.5
Assignee: Sandro Bonazzola
QA Contact: sefi litmanovich
URL:
Whiteboard: integration
Depends On: 1010472
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-23 12:38 UTC by rhev-integ
Modified: 2018-12-03 20:26 UTC (History)
11 users (show)

Fixed In Version: rhevm-log-collector-3.2.2-8.el6ev
Doc Type: Bug Fix
Doc Text:
When rhevm-log-collector attempted to collect logs from Red Hat Enterprise Linux hosts, the process was suspended indefinitely while processing the SELinux sos plugin. This update adds a "-t" flag to the ssh command used in the log collector, which provides a controlling TTY to finish the rhevm-log-collector process after the host sosreport is collected.
Clone Of: 1010472
Environment:
Last Closed: 2013-12-18 13:59:15 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 489813 None None None Never
Red Hat Product Errata RHBA-2013:1835 normal SHIPPED_LIVE rhevm-log-collector bug fix update 2013-12-18 18:56:35 UTC
oVirt gerrit 19471 None None None Never
oVirt gerrit 19578 None None None Never
oVirt gerrit 20456 None None None Never

Description rhev-integ 2013-10-23 12:38:25 UTC
+++ This bug is a RHEV-M zstream clone. The original bug is: +++
+++   https://bugzilla.redhat.com/show_bug.cgi?id=1010472. +++
+++ Requested by "italkohe@redhat.com" +++
======================================================================



----------------------------------------------------------------------
Following comment by dornelas@redhat.com on September 20 at 20:38:03, 2013

Description of problem:  When rhevm-log-collector attempts to collect logs from RHEL hypervisor the process hangs indefinitely while processing the selinux sos plugin because of the following line:

        self.collectExtOutput("ausearch -m avc,user_avc -ts today")



Version-Release number of selected component (if applicable):

rhevm-log-collector-3.2.2-4.el6ev.noarch
sos-2.2-38.el6_4.2.noarch

How reproducible:

100%


Steps to Reproduce:
1.  Run 'rhevm-log-collector' on an environment containing a hypervisor running full RHEL 6



Actual results:

The rhevm-log-collector command never finishes, and sosreport runs indefinitely on the RHEL 6 hypervisor


Expected results:

The rhevm-log-collector command finishes after the host sosreport is collected 


Additional info:

The issue appears to be that the ausearch command requires a controlling TTY(pty), and hangs indefinitely without access to one.  The ssh command that rhevm-log-collector runs does have a controlling TTY.

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on September 23 at 06:26:46, 2013

There is an open bug about ausearch, however it seems that running it through ssh with -t flag is enough for providing the needed TTY.
I just need to check if adding that flag has other implications.

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on September 24 at 14:45:58, 2013

Patch pushed upstream master by James W. Mills.

----------------------------------------------------------------------
Following comment by sbonazzo@redhat.com on September 25 at 13:12:27, 2013

Patch merged upstream master. Pushed and merged also on upstream 3.3 branch.

----------------------------------------------------------------------
Following comment by errata-xmlrpc@redhat.com on September 30 at 08:17:01, 2013

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2013:15255-01
https://errata.devel.redhat.com/advisory/15255

----------------------------------------------------------------------
Following comment by slitmano@redhat.com on October 03 at 07:52:50, 2013

verified on RHEVM 3.3 IS17.
rhevm-log-collector-3.3.0-1.el6ev.noarch
sos-2.2-44.el6.noarch

Comment 1 Sandro Bonazzola 2013-10-24 07:42:14 UTC
patch merged on upstream 3.2 branch.

Comment 3 sefi litmanovich 2013-11-20 16:02:25 UTC
Verified on RHEVM 3.2 sf21.1, with rhevm-log-collector-3.2.2-8.el6ev.

Comment 5 errata-xmlrpc 2013-12-18 13:59:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1835.html


Note You need to log in before you can comment on or make changes to this bug.