Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1022 - RHL installer detected S3V card but assigned SVGA server as the X Server
Summary: RHL installer detected S3V card but assigned SVGA server as the X Server
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-02 02:18 UTC by mangrai
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-11 22:39:29 UTC


Attachments (Terms of Use)

Description mangrai 1999-02-02 02:18:45 UTC
When installing, RHL 5.2 detected S3 Virge 3D card (S3 375
chip) properly. But it assigned SVGA server instead of S3V
server. This problem does not exist in RHL 5.1. 5.1 properly
assigned the correct server.

Comment 1 Aleksey Nogin 1999-02-02 06:46:59 UTC
This is a duplicate of report #313
In new XFree86 SVGA server contains driver for S3 Virge, so installer
was absolutely correct

Comment 2 David Lawrence 1999-03-11 22:39:59 UTC
With release 3.3.2 of XFree86, there are now two servers which support
the
ViRGE family of chips. The XF86_S3V server is a dedicated server which
supports
the S3 ViRGE (86C325), the ViRGE/DX (86C375), ViRGE/GX (86C385) and
the
ViRGE/VX (86C988) chips. New with this release, the above ViRGE
chipsets are
also supported in the XF86_SVGA server, which includes a new ViRGE
driver mak-
ing use of the XAA acceleration architecture and also supports
ViRGE/GX2
(86C357) and ViRGE/MX (86C260) chips now.

------- Additional Comments From   06/05/99 09:17 -------
Even choosing expert mode, the installer will still install SVGA
server instead of the dedicated S3V server. Some card just don't work
with SVGA server.
To work around this, install S3V server's rpm manually. Then replace
XF86_SVGA with XF86_S3V in the /usr/X11R6/bin. Xconfigurator will now
work with XF86_SVGA.


Note You need to log in before you can comment on or make changes to this bug.