Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1021186 - "Soundcard enabled" VM property is not exposed in REST API
Summary: "Soundcard enabled" VM property is not exposed in REST API
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Eldan Shachar
QA Contact: Pavel Novotny
URL:
Whiteboard: virt
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-10-20 08:39 UTC by David Jaša
Modified: 2015-02-17 08:29 UTC (History)
11 users (show)

Fixed In Version: vt3
Doc Type: Enhancement
Doc Text:
Feature: enable controlling sound card availability for vm with rest-api Reason: this was available only with UI, missing in rest-api Result: user can choose to enable/disable sound card for vm using rest-api
Clone Of:
Environment:
Last Closed: 2015-02-17 08:29:43 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30635 master MERGED restapi: Control\view Soundcard property Never
oVirt gerrit 32255 ovirt-engine-3.5 MERGED restapi: Control\view Soundcard property Never

Description David Jaša 2013-10-20 08:39:18 UTC
Description of problem:
"Soundcard Enabled" can only be set in the UI but it's not accessible via API.

Version-Release number of selected component (if applicable):
is19:
rhevm-restapi-3.3.0-0.26.master.el6ev.noarch
rhevm-backend-3.3.0-0.26.master.el6ev.noarc

How reproducible:
always

Steps to Reproduce:
1. perform HTTP GET https://rhevm.example.org/api/vms/VM_UUID
2.
3.

Actual results:
"soundcard enabled" equivalent is not available

Expected results:
"soundcard enabled" equivalent is displayed and can be modified via HTTP PUT

Additional info:

Comment 3 Juan Hernández 2014-02-25 15:10:25 UTC
Michal, looks like this won't make 3.4, can you retarget it?

Comment 4 Eyal Edri 2014-09-10 20:21:48 UTC
fixed in vt3, moving to on_qa.
if you believe this bug isn't released in vt3, please report to rhev-integ@redhat.com

Comment 5 Pavel Novotny 2014-09-12 11:36:16 UTC
rhevm-3.5.0-0.11.beta.el6ev.noarch (vt3).

Confirming that VM/pool VM and template entities have now attribute 'soundcard_enabled'. However it's visible in the response only with use of HTTP header 'All-Content=true'. But...

@Eldan: Is it really desired to have this general VM/template attribute hidden behind the All-Content header? Other similar attributes, like vm.delete_protected or vm.display.smartcard_enabled, are exposed without it.

Comment 6 Eldan Shachar 2014-09-14 07:18:43 UTC
Yes, we talked about it with our REST guy, the soundcard field requires an additional query to the backend\db because it's a device and not an integral part of the VM object like most VM REST fields. 

Because queries may affect performance the fields which require them are currently added under the 'All-Content' header (fields such as RNG and virtioSCSI).

Comment 7 Pavel Novotny 2014-09-15 10:05:56 UTC
(In reply to Eldan Shachar from comment #6)
> Yes, we talked about it with our REST guy, the soundcard field requires an
> additional query to the backend\db because it's a device and not an integral
> part of the VM object like most VM REST fields. 
> 
> Because queries may affect performance the fields which require them are
> currently added under the 'All-Content' header (fields such as RNG and
> virtioSCSI).

I understand, moving to VERIFIED then, rhevm-3.5.0-0.11.beta.el6ev.noarch (vt3).

Comment 8 Omer Frenkel 2015-02-17 08:29:43 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.