Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1019394 - deleteImage task, which was started as part of snapshot creation (with save memory) roll-back remains running forever
Summary: deleteImage task, which was started as part of snapshot creation (with save m...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Arik
QA Contact: Leonid Natapov
URL:
Whiteboard: virt
: 1023730 (view as bug list)
Depends On:
Blocks: 1056598 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-10-15 15:44 UTC by Elad
Modified: 2014-09-18 12:24 UTC (History)
15 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1056598 (view as bug list)
Environment:
Last Closed:
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
logs (deleted)
2013-10-15 15:44 UTC, Elad
no flags Details
logs2 (deleted)
2013-10-16 07:49 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23222 None None None Never
oVirt gerrit 23821 None None None Never

Description Elad 2013-10-15 15:44:02 UTC
Created attachment 812595 [details]
logs

Description of problem:
After a failure in snapshot creation (during createVolume task), vdsm get the request from engine to perform roll-back and start a deleteImage task. This task gets stuck forever on vdsm. User has to stop and clean it manually. 

Version-Release number of selected component (if applicable):
vdsm-4.13.0-0.2.beta1.el6ev.x86_64
libvirt-0.10.2-29.el6.x86_64
rhevm-3.3.0-0.25.beta1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
On a block pool:
- create a vm with 2 disks and run it
- create snapshot to the vm (with 'save memory' check-box checked) and during the createVolume task, restart vdsm service

Actual results:
vdsm gets the request from engine to perform roll-back and delete the image.
deleteImage task starts on vdsm and it won't end forever


Additional info: logs

Comment 3 Elad 2013-10-16 07:49:45 UTC
Created attachment 812795 [details]
logs2

logs2 attached

Comment 5 Arik 2013-10-29 10:49:34 UTC
*** Bug 1023730 has been marked as a duplicate of this bug. ***

Comment 10 Leonid Natapov 2014-02-13 11:06:14 UTC
3.4.0-0.7.beta2.el6.
Vm with 2 disks created and runs. Block connection to storage and creted snapshot. Task fails and roll backs in engine.
Snapshot not created.
---
Vdc Bll exception. With error message VdcBLLException: Failed to create snapshot! (Failed with error VolumeCreationError and code 205)
2014-02-13 12:53:45,415 ERROR [org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand] (org.ovirt.thread.pool-6-thread-23) Transaction rolled-back for command: org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand.
---
After resuming connection checked that there are no running tasks in vdsm on the host. getAllTasksInfo shows no tasks running.

Comment 12 Itamar Heim 2014-06-12 14:10:37 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.