Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 101909 - File "/usr/share/printconf/util/cups_import.py" : local variable 'which' referenced before assignment
Summary: File "/usr/share/printconf/util/cups_import.py" : local variable 'which' refe...
Keywords:
Status: CLOSED DUPLICATE of bug 85363
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-printer
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-07 22:00 UTC by Olivier Baudron
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:01 UTC


Attachments (Terms of Use)

Description Olivier Baudron 2003-08-07 22:00:44 UTC
version of redhat-config-printer is 0.6.69-1

# redhat-config-printer
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer", line 9, in ?
    import queueTree
  File "/usr/share/printconf/util/queueTree.py", line 1085, in ?
    queueTree()
  File "/usr/share/printconf/util/queueTree.py", line 128, in __init__
    if cups_import.import_needed ():
  File "/usr/share/printconf/util/cups_import.py", line 200, in import_needed
    which = which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in which_spooler
    return which
UnboundLocalError: local variable 'which' referenced before assignment

Comment 1 Tim Waugh 2003-08-07 22:05:46 UTC
What does this say?:

/usr/sbin/alternatives --display print

Comment 2 Olivier Baudron 2003-08-07 23:50:41 UTC
Nothing.

Comment 3 Miloslav Trmac 2003-08-08 02:18:41 UTC
This is a duplicate of bug 85363.

Comment 4 Bill Nottingham 2003-08-08 03:18:20 UTC
So it appears.

*** This bug has been marked as a duplicate of 85363 ***

Comment 5 Red Hat Bugzilla 2006-02-21 18:58:01 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.