Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 101839 - Can't run redhat-config-network due to exception in redhat-config-network-gui
Summary: Can't run redhat-config-network due to exception in redhat-config-network-gui
Keywords:
Status: CLOSED DUPLICATE of bug 88147
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-07 14:55 UTC by John
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:00 UTC


Attachments (Terms of Use)

Description John 2003-08-07 14:55:50 UTC
Description of problem:
I have recently installed Redhat 9 on my IBM Thinkpad A22m.  It has both a 
wireless internal ethernet and a PCMCIA 3Com 10/100 Lan PC Card with XJack 
connector.  Model 3CXFE574BT.

When I boot all responses are OK.  

If I attempt to remove the PCMCIA card I get a beep and when I reinstall it a 
get the double beep.  So, I assume the system is recognizing my card properly.

After getting logged in I attempt to run redhat-config-network to get 
configured.  The following exception occurs.

I had to type this in from the exception error display because I have
no networking.

An unhandled exception has occured.  Component: redhat-config-network
version 1.2.0

Summary: TB /usr/src/build/228093-
i386/install/usr/lib/python/sre.py:137:search:TypeError:epected string or buffer
Traceback (most recent call last):
File "/usr/sbin/redhat-config-network-gui", line 154, in ?
  window = mainDialog()

File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 154, in__init__
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 225, in load__
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 232, in loadDevices__
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/NCDeviceList.py", line 210, in getDeviceList
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/NCDeviceList.py", line 117, in load
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/plugins/NCDevWireless.py", line 34, in load
File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/NCWireless.py", line 52, in load
File "usr/src/build/228093-i386/install/usr/lib/python2.2/sre.py", line 137, in 
search
  return _compile(pattern, flags).search(string)
TypeError: expected string or buffer


How do I get around this problem?

Thanks.



Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1.Boot
2.Login as root
3.Choose System Setting -> Network
    
Actual results:  Exception panel is displayed


Expected results: Network configuration to be handled


Additional info:

Comment 1 Harald Hoyer 2004-09-21 12:03:14 UTC
An errata has been issued which should help the problem described in
this bug report. 
This report is therefore being closed with a resolution of ERRATA. For
more information
on the solution and/or where to find the updated files, please follow
the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html


*** This bug has been marked as a duplicate of 88147 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:00 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.