Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1018250 - ISO/NFS connection stored in database even if action did not succeed
Summary: ISO/NFS connection stored in database even if action did not succeed
Keywords:
Status: CLOSED DUPLICATE of bug 991470
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.3.0
Assignee: nobody nobody
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-11 14:34 UTC by Lukas Svaty
Modified: 2016-02-10 19:27 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-13 12:31:02 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)

Description Lukas Svaty 2013-10-11 14:34:39 UTC
Description of problem:
When importing storage as ISO/NFS and action fails connection is still stored in database in table storage_server_connections

Version-Release number of selected component (if applicable):
is18

How reproducible:
100%

Steps to Reproduce:
1. Create Export NFS storage a
2. Detach and remove from engine storage a 
3. Import storage a as ISO/NFS storage
4. Action fails however it is still stored in storage_server_connections table

Actual results:
Conenction added to storage_server_connections table with type 1

Expected results:
Fail to add storage when engine fails to add storage (in database too :)

Additional info:
Can provide other than engine.log (see bellow) if necessary (hopefully not)
engine.log of the action:

2013-10-11 16:22:35,899 INFO  [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-/127.0.0.1:8702-6) Running command: AddStorageServerConnectionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: System
2013-10-11 16:22:35,900 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (ajp-/127.0.0.1:8702-6) START, ConnectStorageServerVDSCommand(HostName = 10.34.62.204, HostId = fb9c2e50-bc05-4cce-b584-192c49f26b27, storagePoolId = 00000000-0000-0000-0000-000000000000, storageType = NFS, connectionList = [{ id: null, connection: 10.34.63.202:/mnt/export/nfs/lv3/lsvaty/nfs01, iqn: null, vfsType: null, mountOptions: null, nfsVersion: null, nfsRetrans: null, nfsTimeo: null };]), log id: 1a4a5406
2013-10-11 16:22:36,283 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.ConnectStorageServerVDSCommand] (ajp-/127.0.0.1:8702-6) FINISH, ConnectStorageServerVDSCommand, return: {00000000-0000-0000-0000-000000000000=0}, log id: 1a4a5406
2013-10-11 16:22:36,427 INFO  [org.ovirt.engine.core.bll.storage.AddStorageServerConnectionCommand] (ajp-/127.0.0.1:8702-6) Lock freed to object EngineLock [exclusiveLocks= key: 10.34.63.202:/mnt/export/nfs/lv3/lsvaty/nfs01 value: STORAGE_CONNECTION
, sharedLocks= ]
2013-10-11 16:22:36,444 INFO  [org.ovirt.engine.core.bll.storage.GetExistingStorageDomainListQuery] (ajp-/127.0.0.1:8702-10) START, GetExistingStorageDomainListQuery(refresh: true, filtered: false), log id: 4b916061
2013-10-11 16:22:36,446 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMGetStorageDomainsListVDSCommand] (ajp-/127.0.0.1:8702-10) START, HSMGetStorageDomainsListVDSCommand(HostName = 10.34.62.204, HostId = fb9c2e50-bc05-4cce-b584-192c49f26b27, storagePoolId=00000000-0000-0000-0000-000000000000, storageType=NFS, storageDomainType=ISO, path=10.34.63.202:/mnt/export/nfs/lv3/lsvaty/nfs01), log id: 3eb85b36
2013-10-11 16:22:39,654 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMGetStorageDomainsListVDSCommand] (ajp-/127.0.0.1:8702-10) FINISH, HSMGetStorageDomainsListVDSCommand, return: [], log id: 3eb85b36
2013-10-11 16:22:39,654 INFO  [org.ovirt.engine.core.bll.storage.GetExistingStorageDomainListQuery] (ajp-/127.0.0.1:8702-10) FINISH, GetExistingStorageDomainListQuery, log id: 4b916061
2013-10-11 16:22:39,827 INFO  [org.ovirt.engine.core.bll.storage.DisconnectStorageServerConnectionCommand] (ajp-/127.0.0.1:8702-13) Running command: DisconnectStorageServerConnectionCommand internal: false. Entities affected :  ID: aaa00000-0000-0000-0000-123456789aaa Type: System
2013-10-11 16:22:39,829 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (ajp-/127.0.0.1:8702-13) START, DisconnectStorageServerVDSCommand(HostName = 10.34.62.204, HostId = fb9c2e50-bc05-4cce-b584-192c49f26b27, storagePoolId = 00000000-0000-0000-0000-000000000000, storageType = NFS, connectionList = [{ id: null, connection: 10.34.63.202:/mnt/export/nfs/lv3/lsvaty/nfs01, iqn: null, vfsType: null, mountOptions: null, nfsVersion: null, nfsRetrans: null, nfsTimeo: null };]), log id: 5bf67675
2013-10-11 16:22:41,968 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.DisconnectStorageServerVDSCommand] (ajp-/127.0.0.1:8702-13) FINISH, DisconnectStorageServerVDSCommand, return: {00000000-0000-0000-0000-000000000000=0}, log id: 5bf67675
2013-10-11 16:27:35,371 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (pool-5-thread-46) starting ProcessDomainRecovery for domain ca414eb9-98ab-422f-8c4e-c2c513231058:str-01-jbelka-export
2013-10-11 16:27:35,426 WARN  [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (pool-5-thread-46) Storage domain ca414eb9-98ab-422f-8c4e-c2c513231058:str-01-jbelka-export is not visible to one or more hosts. Since the domains type is ImportExport, hosts status will not be changed to non-operational
2013-10-11 16:27:44,794 WARN  [org.ovirt.engine.core.vdsbroker.irsbroker.IrsBrokerCommand] (pool-5-thread-46) domain ca414eb9-98ab-422f-8c4e-c2c513231058:str-01-jbelka-export in problem. vds: 10.34.62.204

Comment 2 Allon Mureinik 2013-10-13 12:31:02 UTC

*** This bug has been marked as a duplicate of bug 991470 ***

Comment 3 Lukas Svaty 2014-06-09 11:25:43 UTC
no need for logs anymore as it was marked as duplicate


Note You need to log in before you can comment on or make changes to this bug.