Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1017030 - [Admin Portal] User $user@$domain attach to VM <UNKNOWN> in VM Pool test was initiated by $user.
Summary: [Admin Portal] User $user@$domain attach to VM <UNKNOWN> in VM Pool test was ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Shahar Havivi
QA Contact: Pavel Novotny
URL:
Whiteboard: virt
Depends On: 1121954
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-10-09 07:50 UTC by Jiri Belka
Modified: 2015-02-17 08:28 UTC (History)
8 users (show)

Fixed In Version: vt2.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 08:28:09 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
engine.log (deleted)
2013-10-09 07:50 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 27729 master MERGED core: Audit log messages - grammar fix Never
oVirt gerrit 31492 master MERGED engine: AudibleLogBase vmid need to set for logging info Never
oVirt gerrit 31546 ovirt-engine-3.5 MERGED engine: AudibleLogBase vmid need to set for logging info Never

Description Jiri Belka 2013-10-09 07:50:14 UTC
Created attachment 809731 [details]
engine.log

Description of problem:

User vdcadmin@brq-ipa.rhev.lab.eng.brq.redhat.com attach to VM <UNKNOWN> in VM Pool test was initiated by vdcadmin.

* 'attach' vs 'attaches/attached' or...??? I'm not native English speaker but seems strange completely, please consult with native English speaker.

* <UNKNOWN> ? (test-X was the case here)

Version-Release number of selected component (if applicable):
is17

How reproducible:
100%

Steps to Reproduce:
1. create a automatic prestarted pool (6 vms, 3 prestarted, 6 max per user)
2. in User Portal click 3 times on pool's "Run" button to get 3 VMs from pool
3.

Actual results:
event is strange

Expected results:


Additional info:

Comment 1 Shahar Havivi 2014-05-15 11:44:04 UTC
Cannot reproduce the <UNKNOWN> user (we fix several of bugs regarding this issue).
regarding the error message, I found a couple of other messages that need to be fix, so the following patch will fix this 3 audit log messages:

-User ${AdUserName} attach to VM ${VmName} in VM Pool ${VmPoolName} was initiated by ${UserName}.
-User ${AdUserName} attach to VM ${VmName} in VM Pool ${VmPoolName} has been completed.
-Failed to complete user ${AdUserName} attach to VM ${VmName} in VM Pool ${VmPoolName}.
+Attaching User ${AdUserName} to VM ${VmName} in VM Pool ${VmPoolName} was initiated by ${UserName}.
+User ${AdUserName} successfully attached to VM ${VmName} in VM Pool ${VmPoolName}.
+Failed to attach user ${AdUserName} to VM ${VmName} in VM Pool ${VmPoolName}.

Comment 2 Pavel Novotny 2014-08-13 14:29:11 UTC
FailedQA in ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch (rc1).

The grammar has been corrected, but the VM name the user is attached to is still '<UNKNOWN>'.

The event is now:

"Attaching User user1 to VM <UNKNOWN> in VM Pool disk-vm was initiated by user1."

but should be like:

"Attaching User user1 to VM disk-vm-1 in VM Pool disk-vm was initiated by user1."

Comment 4 Pavel Novotny 2014-09-12 12:29:42 UTC
Verified in rhevm-3.5.0-0.11.beta.el6ev.noarch (vt3).

In User Portal, when user "user1" takes a VM from prestarted pool, the emitted event is now correct, e.g.:

  Attaching User user1 to VM win7-3 in VM Pool win7 was initiated by user1.

Comment 5 Omer Frenkel 2015-02-17 08:28:09 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.