Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1016799 - rhn-upgrade doc/satellite-and-os-upgrade-postgresql.txt needs update
Summary: rhn-upgrade doc/satellite-and-os-upgrade-postgresql.txt needs update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 560
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Lukas Pramuk
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2013-10-08 17:24 UTC by DzungDo
Modified: 2013-12-17 07:05 UTC (History)
4 users (show)

Fixed In Version: rhn-upgrade-5.6.0.40-1
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Fix: This is a simple upgrade documentation fix explaining our customers in more details how to install rhn-upgrade package on their Satellite 5.6 machine. Result:
Clone Of:
Environment:
Last Closed: 2013-12-12 10:45:31 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1828 normal SHIPPED_LIVE Red Hat Satellite rhn-upgrade bug fix update 2013-12-12 15:44:13 UTC

Description DzungDo 2013-10-08 17:24:31 UTC
Description of problem:

Step 3 (right before step 4) tells reader to either install rhn-upgrade or download the rhn-upgrade package for the newly installed Satellite 5.6 server. Should we install rhn-upgrade on the Satellite 5.6???

The rhn-upgrade is *NOT* part of the redhat-rhn-satellite-5.6-server-x86_64-6 channel, thus, we cannot install rhn-upgrade on this Satellite 5.6 server if we wanted to. 

If this rhn-upgrade would be a part of this channel (at this time it is not), we need to include instruction for reader to activate this Satellite 5.6 server before it can get the packages in the redhat-rhn-satellite-5.6-server-x86_64-6 channel.


Version-Release number of selected component (if applicable):
rhn-upgrade-5.6.0.38-1.el6sat.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. install rhn-upgrade-5.6.0.38-1.el6sat.noarch.rpm
2. look into the doc/ directory
3.

Actual results:
Instruction not clear

Expected results:


Additional info:

Comment 1 Milan Zázrivec 2013-10-08 19:08:16 UTC
Point 3 of satellite-upgrade-postgresql.txt (currently mentioned in
the bug report summary) contains instructions to convert Satellite filer
(/var/satellite).

Point 4 of the same document contains instructions to rebuild search
indexes.

Nowhere in this document have I found a single occurence of the "rhn-upgrade"
string.

Which document are we really talking about here?

Comment 2 DzungDo 2013-10-08 20:52:38 UTC
Package = rhn-upgrade.noarch 0:5.6.0.38-1.el6sat
File = /etc/sysconfig/rhn/satellite-upgrade/doc/satellite-and-os-upgrade-postgresql.txt

...
...
100 You will see a message advising you to create the satellite administrator
101 account. Ignore this message.
102
103 At the end of Red Hat Satellite installation, stop your Satellite by:
104
105     /usr/sbin/rhn-satellite stop
106
107 and if you installed embedded PostgreSQL variant, start the database with:
108
109     service postgresql start
110
111 Install the rhn-upgrade package on new server, either:
112
113     yum install rhn-upgrade
114
115 or by downloading the rpm manually and running:
116
117     rpm -ivh rhn-upgrade-*.rpm
118
119
120 4. Import database schema.
...
...

Comment 3 Milan Zázrivec 2013-10-09 08:47:21 UTC
All right, thank you.

True, you cannot yum install rhn-upgrade on a 5.6 Satellite. The package
is not available in 5.6 channels + disconnected Satellites do not have
that option.

The instructions here should be clearer, we could perhaps instruct our
customers to download & install the rhn-upgrade package manually.

Comment 6 Lukas Pramuk 2013-12-02 14:14:50 UTC
VERIFIED. rhn-upgrade-5.6.0.41-1.el6sat.noarch

REPRO:
# less /etc/sysconfig/rhn/satellite-upgrade/doc/satellite-and-os-upgrade-{oracle,postgresql}.txt
...
Install the rhn-upgrade package on new server, either:

    yum install rhn-upgrade

or by downloading the rpm manually and running:

    rpm -ivh rhn-upgrade-*.rpm


4. {Import database schema.|Restore and upgrade database schema.}
...


FIX:
# less /etc/sysconfig/rhn/satellite-upgrade/doc/satellite-and-os-upgrade-{oracle,postgresql}.txt
...

Install the rhn-upgrade package on new server. Download the latest version
of rhn-upgrade from Red Hat Customer Portal and install the package by running:

    rpm -ivh rhn-upgrade-*.rpm


4. {Import database schema.|Restore and upgrade database schema.}
...

Comment 8 errata-xmlrpc 2013-12-12 10:45:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1828.html


Note You need to log in before you can comment on or make changes to this bug.