Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1015321 - [RFE] Add the ability to import a preconfigured Storage Data Domain into RHEV.
Summary: [RFE] Add the ability to import a preconfigured Storage Data Domain into RHEV.
Keywords:
Status: CLOSED DUPLICATE of bug 716511
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.4.0
Assignee: Andrew Cathrow
QA Contact: yeylon@redhat.com
URL:
Whiteboard: storage
: 971939 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-10-03 22:54 UTC by Marina
Modified: 2016-04-18 07:02 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-03 16:07:40 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)

Description Marina 2013-10-03 22:54:49 UTC
Add the ability to import a preconfigured Storage Data Domain into RHEV.

2. Who is the customer behind the request?
Account: name (acct #) GSS
TAM customer: yes
SRM customer: yes
Strategic: yes

3. What is the nature and description of the request?
Add the ability to import a preconfigured Storage Data Domain into RHEV.

4. Why does the customer need this? (List the business requirements here)
Scenario I:
There is a big amount of cases where customer looses his RHEV-M environment completely and we need to provide manual instructions to attach the domain to the new RHEV setup or save the VMs on it in other ways. The instructions are complicated and sometimes are not good enough to recover the information. Especially assuming the fact, that we cannot use iSCSI/FC data domain as export domain any more.
Scenario II:
Local storage defined on the host.
There is no way, afaik, to reinstall the host without loosing the information on that domain.
(Maybe this should be a different RFE to recognize preconfigured local storage on new host registration?)

5. How would the customer like to achieve this? (List the functional requirements here)
Add a new option to "Import Domain" dialogue on the Storage Tab on the Admin Portal.
Under "Domain Function / Storage Type" add new option: "Preconfigured Data Domain".
Add a red warning/confirmation message to the user, that this Domain is not in use in any other RHEV setup, otherwise it will make other setup non-operational.
Once confirmed, RHEV would clear the previous SPM status and other relevant information and add this domain to the current setup.

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
Just do it.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?
There is this one: https://bugzilla.redhat.com/show_bug.cgi?id=716511
It is related, but not satisfying enough.
The solution should be simple. And there is not reason not add this RFE to RHEV.

8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?
ASAP.

9. Is the sales team involved in this request and do they have any additional input?
N/A
10. List any affected packages or components.
several. overall storage team.
11. Would the customer be able to assist in testing this functionality if implemented?
Sure.

Comment 1 Itamar Heim 2013-10-04 15:05:39 UTC
dup of 716511?

Comment 2 Marina 2013-10-04 15:32:34 UTC
Itamar, see #7 on bz description, if it answers your question.
I prefer the implementation described in here.

Comment 4 Itamar Heim 2013-12-03 11:22:58 UTC
*** Bug 971939 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.