Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1014986 - satellite-upgrade-estimates traceback
Summary: satellite-upgrade-estimates traceback
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 560
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Milan Zázrivec
QA Contact: Lukas Pramuk
URL:
Whiteboard:
: 1014999 (view as bug list)
Depends On:
Blocks: 465198 sat560-triage
TreeView+ depends on / blocked
 
Reported: 2013-10-03 09:23 UTC by Matej Kollar
Modified: 2018-12-03 20:09 UTC (History)
8 users (show)

Fixed In Version: rhn-upgrade-5.6.0.39-1
Doc Type: Bug Fix
Doc Text:
Cause: A bug in one of satellite upgrade helper scripts. Consequence: satellite-upgrade-estimates script would throw a traceback when ran on Satellite 5.5 Fix: Result: no more traceback when running the mentioned script on Satellite 5.5 (i.e. when upgrading from Satellite 5.5)
Clone Of:
Environment:
Last Closed: 2013-10-10 11:59:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1417 normal SHIPPED_LIVE Red Hat Satellite server rhn-upgrade bug fix update 2013-10-10 15:57:10 UTC

Description Matej Kollar 2013-10-03 09:23:42 UTC
Description of problem: Obtaining upgrade estimates with satellite-upgrade-estimates produces traceback when both questions are answered positively (y).

Version-Release number of selected component: rhn-upgrade-5.6.0.38-1.el6sat

How reproducible: always/deterministic

Steps to Reproduce:
  1. Follow instructions in doc/preparations.txt up to point where
     you are requested to run satellite-upgrade-estimates.
  2. Run it.
  3. Answer "y" to both questions.

Actual results:

> Computing ...
> Traceback (most recent call last):
>   File "/etc/sysconfig/rhn/satellite-upgrade/scripts/satellite-upgrade-estimates", line 212, in <module>
>     populate_segment_sizes()
>   File "/etc/sysconfig/rhn/satellite-upgrade/scripts/satellite-upgrade-estimates", line 84, in populate_segment_sizes
>     segment_sizes[segment_name] = h.fetchall_dict()[0]['bytes']
> TypeError: 'NoneType' object is unsubscriptable

Expected results:

  Upgrade estimates

Comment 1 Milan Zázrivec 2013-10-03 09:28:28 UTC
This is reproducible only when upgrading / migrating from Satellite 5.5

Comment 2 Milan Zázrivec 2013-10-03 09:47:27 UTC
*** Bug 1014999 has been marked as a duplicate of this bug. ***

Comment 8 Lukas Pramuk 2013-10-06 19:39:39 UTC
VERIFIED. rhn-upgrade-5.6.0.39-1.el6sat.noarch

# /etc/sysconfig/rhn/satellite-upgrade/scripts/satellite-upgrade-estimates
Will you be upgrading both the operating system and Red Hat Satellite? [N] y
Will you be migrating your Red Hat Satellite database from Oracle to PostgreSQL? [N] y

Computing ...

* Approximate disk space size required for PostgreSQL database: 4 - 6 GB

satellite-and-os-upgrade-postgresql.txt, point 1:
* Creating database schema export should take approximately 00:30 (HH:MM)

satellite-and-os-upgrade-postgresql.txt, point 3:
* OS and Red Hat Satellite installation should take approximately: 02:00 (HH:MM)

satellite-and-os-upgrade-postgresql.txt, point 4:
* Import of Red Hat Satellite schema should take approximately: 00:30 (HH:MM)

# /etc/sysconfig/rhn/satellite-upgrade/scripts/satellite-upgrade-estimates
Will you be upgrading both the operating system and Red Hat Satellite? [N] 
Will you be migrating your Red Hat Satellite database from Oracle to PostgreSQL? [N] y

Computing ...

* Approximate disk space size required for PostgreSQL database: 4 - 6 GB

satellite-upgrade-postgresql.txt, point 1:
* Command line part of Red Hat Satellite upgrade should take approximately: 00:45 (HH:MM)
* Migration of database data from Oracle to PostgreSQL should take approximately: 00:30 (HH:MM)

Comment 10 errata-xmlrpc 2013-10-10 11:59:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1417.html


Note You need to log in before you can comment on or make changes to this bug.