Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1014326 - Adding a new VM and choosing the OS of any linux, prevents you from changing the time zone.
Summary: Adding a new VM and choosing the OS of any linux, prevents you from changing ...
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
: 3.5.0
Assignee: Martin Betak
QA Contact: Pavel Novotny
Whiteboard: virt
Depends On:
Blocks: 902298 rhev3.5beta 1156165
TreeView+ depends on / blocked
Reported: 2013-10-01 17:43 UTC by Bill Sanford
Modified: 2019-04-16 14:08 UTC (History)
16 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2015-02-11 17:55:21 UTC
oVirt Team: ---
Target Upstream Version:

Attachments (Terms of Use)

System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2015:0158 normal SHIPPED_LIVE Important: Red Hat Enterprise Virtualization Manager 3.5.0 2015-02-11 22:38:50 UTC
oVirt gerrit 26891 master MERGED frontend: Enable edit of time zone for Linux OS Never

Description Bill Sanford 2013-10-01 17:43:25 UTC
Description of problem:
Create a new VM and in the "New Virtual Machine" dialog box, if you choose any RHEL or linux OS, the Time Zone is grayed out and stuck on the default TZ of GMT and you can not change it to the appropriate TZ. If you choose Windows as the VM, you can choose the TZ.

Version-Release number of selected component (if applicable):
RHEV-M 3.3 (is16)

How reproducible:

Steps to Reproduce:

Actual results:

Expected results:

Additional info:

Comment 1 Bill Sanford 2013-10-01 17:46:59 UTC
I was also running the whole RHEV-M setup on RHEL 6.4 GA.

Comment 2 Itamar Heim 2013-10-01 20:32:47 UTC
why regression? this is the same as 3.2.
why testblocker? what is it preventing you from testing?

timezone via initial boot is only for sysprep/windows.
runonce has cloud-init timezone support for linux.

maybe worth cleaning up a bit more by merging the fields/flows between the different OSs / making it clear if using the sysprep provisioning or the cloud-init provisioning

Comment 3 Michal Skrivanek 2014-01-31 11:10:30 UTC
sysprep/cloudinit is supposed to be taken care of by "vminit" feature in 3.4.
the actual VM's start time still behaves the same…maybe time to allow to change it anytime and allow for Linux as well

Comment 4 Michal Skrivanek 2014-02-28 08:05:33 UTC
side note: the TZ setting actually works now with bug 1062615 fixed.

I'm keeping this bug for the enhancement to un-gray the TZ selection for Linux OSes. There needs to be a (?) thingie to explain the default should be UTC as most Linux setups expect BIOS time in UTC. 
I'd probably reset the TZ on OS change from Win to Linux to UTC 

(targeting 3.5, the original problem is to be solved in the guest by setting the right TZ, which is an offset from UTC)

Comment 5 Pavel Novotny 2014-08-07 12:16:09 UTC
Verified in ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch (rc1).

Time zone can be changed for all VMs with Linux-based OS: Other OS, Linux, Debian, FreeBSD, RHEL, SUSE, Ubuntu.

Comment 7 errata-xmlrpc 2015-02-11 17:55:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.