Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 101221 - mozilla spawns zombie netstat children
Summary: mozilla spawns zombie netstat children
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: mozilla
Version: beta1
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
: 157731 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-30 08:19 UTC by Barry K. Nathan
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-26 18:55:06 UTC


Attachments (Terms of Use)

Description Barry K. Nathan 2003-07-30 08:19:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Sometimes Mozilla spawns netstat processes that become defunct. I don't yet know
what circumstances cause this.

Version-Release number of selected component (if applicable):
mozilla-1.4-12, net-tools-1.60-18.1

How reproducible:
Sometimes

Steps to Reproduce:
1. Run Mozilla.
2. ???  :(
    

Actual Results:
[root@i5000e root]# ps -ef|egrep '([n]etstat|[m]ozilla)'
barryn    1787     1  2 00:07 ?        00:01:43 /usr/lib/mozilla-1.4/mozilla-bin
-UILocale en-US
barryn    1807  1787  0 00:07 ?        00:00:00 [netstat <defunct>]
[root@i5000e root]#


Expected Results:
[root@i5000e root]# ps -ef|egrep '([n]etstat|[m]ozilla)'
barryn    1787     1  2 00:07 ?        00:01:43 /usr/lib/mozilla-1.4/mozilla-bin
-UILocale en-US
[root@i5000e root]#

Additional info:

I'm sorry that this report is so vague, but this is all I've been able to come
up with so far. If I can figure anything else out, I'll post more comments to
this bug.

Comment 1 Christopher Blizzard 2003-08-26 18:55:06 UTC
It's intentional.  It's part of how the SSL libraries generate random
information for the crypto routines.

Comment 2 Radek Vokal 2005-05-16 07:49:52 UTC
*** Bug 157731 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.