Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1012027 - Config-file comparison does not notice permission change.
Summary: Config-file comparison does not notice permission change.
Keywords:
Status: CLOSED DUPLICATE of bug 1004746
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2013-09-25 15:02 UTC by Matej Kollar
Modified: 2015-07-26 22:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-22 12:54:50 UTC


Attachments (Terms of Use)

Description Matej Kollar 2013-09-25 15:02:48 UTC
Description of problem: Configuration files as specified in channels are have not only their content but other properties as well, namely file permissions.
Change in those might be of interest, as some programs refuse to operate in case that configuration files they use have inappropriate permissions (for example if they are word-readable). Therefore it can be considered issue that comparing actual config files with those specified in satellite does not notice difference in permissions.

Version-Release number of selected component:

  rhncfg-actions-5.10.55-5.el6sat
  rhncfg-5.10.55-5.el6sat
  rhncfg-client-5.10.55-5.el6sat

How reproducible: always/deterministic


Steps to Reproduce:

  1. Create configuration channel, create some configuration file
  2. Add system to channel, deploy file
  3. change permissions on file (not content), schedule compare file:
        Systems -> <system>
          -> Configuration (provisioning entitilement needed)
          -> Compare files

Actual results:
  no changes are reported

Expected results:
  note about changed permissions

Additional info:
  similarly we should be able to notice selinux context change, owner, group...

  trying to identify change of name would not be good idea, as it is identifying
  info, in that case reporting missing (or changed content if two files are
  swapped) would be ok (case where files are swapped but content is
  same is trivial as it is not distinguishable from "valid" state).

Comment 1 Dimitar Yordanov 2014-07-22 12:54:50 UTC

*** This bug has been marked as a duplicate of bug 1004746 ***


Note You need to log in before you can comment on or make changes to this bug.