Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1009 - login calls pam_close_session before executing the shell
Summary: login calls pam_close_session before executing the shell
Keywords:
Status: CLOSED DUPLICATE of bug 201
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-31 18:38 UTC by felipe
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-02-02 14:34:33 UTC


Attachments (Terms of Use)

Description felipe 1999-01-31 18:38:38 UTC
In util-linux 2.8, a piece of code of login.c was
eliminated. This code waited for the shell to end to call
pam_close_session. So, the version that comes with redhat
5.2 calls pam_close_session before executing the shell
instead of waiting for it to end and then close the session.
The bug is fixed since util-linux-2.9c

Comment 1 Aleksey Nogin 1999-02-02 06:24:59 UTC
This is a duplicate of #201

Comment 2 Jeff Johnson 1999-02-02 14:34:59 UTC
*** This bug has been marked as a duplicate of 201 ***


Note You need to log in before you can comment on or make changes to this bug.