Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1008 - control-panel is a runaway process after root logout.
Summary: control-panel is a runaway process after root logout.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: control-panel
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 853 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-31 18:28 UTC by cjt08287
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-02-01 15:24:21 UTC


Attachments (Terms of Use)

Description cjt08287 1999-01-31 18:28:09 UTC
If control-panel is not closed before logging out as root,
then subsequent user logins will experience 100% of their
CPU time being consumed by this runaway process until it is
killed by root.

Comment 1 Bill Nottingham 1999-02-01 15:24:59 UTC
gtk bug. fixed in the later development gtk releases.

Comment 2 Michael K. Johnson 1999-02-10 18:19:59 UTC
*** Bug 853 has been marked as a duplicate of this bug. ***

Running on a pentium 83 system (16 MB ram) with runlevel 5
as default.

Logging on as Root from XDM starts the control panel
automatically.   However, when one logs off, the control
panel process does _not_ end, and it becomes a runaway
process.  This is a fairly significant bug since even one of
these runaway processes slows down the system..  In cases
where three or four of these control-panel runaway processes
are running in the background, the computer can be slowed
down VERY badly.

The workaround is to kill the process manually before
logging out as root.  Alternatively, a superuser can kill
all the processes later, providing that he/she knows about
this problem.


------- Additional Comments From dkl@redhat.com  01/18/99 15:39 -------
I have been able to replicate this in the test lab. A runaway control
panel is left for every login. SO if the root user were to login
several times without closing the control-panel properly, then there
is a control-panel process for each login. This has been assigned to a
developer for further review.

------- Additional Comments From ayn2@cornell.edu  02/02/99 01:22 -------
This is a duplicate of #1008 (which is reported fixed by the new gtk)

------- Email Received From  michael james obrien <mobrien@unm.edu> 02/16/99 17:17 -------


Note You need to log in before you can comment on or make changes to this bug.