Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1007998 - Unable to disable activation keys
Summary: Unable to disable activation keys
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API
Version: 560
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2013-09-13 17:50 UTC by Matej Kollar
Modified: 2013-12-17 06:55 UTC (History)
4 users (show)

Fixed In Version: spacewalk-java-2.0.2-49
Doc Type: Bug Fix
Doc Text:
Consequence: WebUI incorrectly showed disabled activation keys as being enabled. Result: WebUI correctly shows activation keys enabled or disabled according to their state.
Clone Of:
Environment:
Last Closed: 2013-12-12 10:04:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1827 normal SHIPPED_LIVE Red Hat Satellite server bug fix update 2013-12-12 15:03:51 UTC

Description Matej Kollar 2013-09-13 17:50:36 UTC
Description of problem:

   Using activationkey.setDetails to disable looks like successfull,
   but does not work.


Version-Release number of selected component: spacewalk-java-2.0.2-34


How reproducible: always/deterministic

Steps to Reproduce:

  1. Create activation key (will be reated like enabled)
  2. call  activationkey.setDetails(key, label, {'disabled': True})

Actual results: activation key is still enabled.

Expected results: activation key is disabled.

Additional info:

  * I am unable to test transition disabled -> enabled as I am unable to
    obtain disabled activation key
  * Regression against 550

Comment 1 Matej Kollar 2013-09-13 17:53:01 UTC
It is also not possible to change this using WebIU.

Comment 4 Tomas Lestach 2013-09-16 15:40:17 UTC
It looks like only WebUI incorrectly displays the dis/enabled key property. Changes are done in the DB.
Need to check the WebUI selection sync.

Comment 5 Tomas Lestach 2013-09-18 09:23:37 UTC
The bug does not show in Spacewalk. However, here's the fix ...

spacewalk.git: 37c5a382a4f5d152fce0d26bbcf4a0caa341f531

Comment 10 errata-xmlrpc 2013-12-12 10:04:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1827.html


Note You need to log in before you can comment on or make changes to this bug.