Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 100461 - HTTP 500 error when searches return no results
Summary: HTTP 500 error when searches return no results
Keywords:
Status: CLOSED DUPLICATE of bug 81044
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: htdig
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-22 18:15 UTC by Brent Bourgoine
Modified: 2015-03-05 01:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Brent Bourgoine 2003-07-22 18:15:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030530 Galeon/1.3.5

Description of problem:
Command-line htsearch appears to work fine, and returns the expected html output.

Searching via the same htsearch binary from the browser causes 2 things to happen:

1 - Any search that returns no results returns an HTTP 500 error, rather than
the expected "No results found" page.  Apache's error log shows only a
"Premature end of script headers" error, with no preceding information regarding
the exact cause.

2 - Any search that *does* return results seems to be truncated (I believe this
part to be the same issue as bug 81044)



Version-Release number of selected component (if applicable):
htdig-3.2.0-2.011302

How reproducible:
Always

Steps to Reproduce:
1. 'rundig' on the site in question to generate htdig's database.
2. Access the search page from a web browser.
3. Search for a string that returns no results.
    

Actual Results:  HTTP 500 Error to the browser.

Apache error log shows:
[Tue Jul 22 13:26:31 2003] [error] [client 65.211.1.194] Premature end of script
headers: /web/kavi/dotorg/sites/list-server/htdocs/htdig/bin/htsearch

Expected Results:  "No Results Found" page from htdig

Additional info:

Related post to htdig's mailing list from another affected user with 2.1AS:
http://sourceforge.net/mailarchive/forum.php?thread_id=2696615&forum_id=2691

As I said above, this may be related to bug 81044 as well.

Comment 1 Phil Knirsch 2003-09-02 14:09:25 UTC
It is. And see my comments for that bug, too. Next enterprise version will
contain an older version of htdig again which works fine.

Also planing on doing an errata for AS2.1

Read ya, Phil

*** This bug has been marked as a duplicate of 81044 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:57:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.