Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1002443 - filtering with non existing plugin returns empty list
Summary: filtering with non existing plugin returns empty list
Keywords:
Status: CLOSED DUPLICATE of bug 1002444
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-scheduler-proxy
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.3.1
Assignee: Doron Fediuck
QA Contact: Artyom
URL:
Whiteboard: sla
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-08-29 08:36 UTC by Laszlo Hornyak
Modified: 2016-02-10 20:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-22 11:55:41 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 18728 None None None Never

Description Laszlo Hornyak 2013-08-29 08:36:01 UTC
Description of problem:
filtering with non existing plugin returns empty list

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. call filter with a plugin that does not exist
2. get the result

Actual results:
empty list

Expected results:
exception

Additional info:

Comment 1 Laszlo Hornyak 2013-09-02 11:21:21 UTC
proxy part merged c9773f898698f2b84b47e3410a4357698cb66b6c

Comment 5 Artyom 2013-11-28 15:24:38 UTC
Verified on is25, no exception in engine.log

Comment 6 Artyom 2013-12-05 14:54:05 UTC
After discussion with Doron and Martin revealed that, if filter is corrupted or missing external scheduler must return all hosts and vm must run.

Comment 7 Artyom 2013-12-06 06:56:25 UTC
Checked on is26,
Can't run vm, when corrupted filter function is added to ovirt-sheduler-proxy
engine.log:
Cant find VDS to run the VM 687e60b6-5632-4c97-80c1-23a63f61c550 on, so this VM will not be run

ovirt-sheduler-proxy.log
Fri, 06 Dec 2013 08:53:55 DEBUG    [process:MainProcess, thread:Thread-7] [Request:2c9637ac-5e43-11e3-9f2b-001a4a1697fa][Method:run_filters] - Waiting for filters to finish
Fri, 06 Dec 2013 08:53:55 ERROR    [process:MainProcess, thread:Thread-8] [Request:2c9637ac-5e43-11e3-9f2b-001a4a1697fa][Method:PythonMethodRunner] - script ['python', '-c', "import max_vm_filter; max_vm_filter.max_vms().do_filter(['1ab5d0d9-5f2d-4994-8f6e-773870b1d1a0'], '687e60b6-5632-4c97-80c1-23a63f61c550', {})"] got error Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named max_vm_filter

Fri, 06 Dec 2013 08:53:55 DEBUG    [process:MainProcess, thread:Thread-7] [Request:2c9637ac-5e43-11e3-9f2b-001a4a1697fa][Method:run_filters] - Aggregating results
Fri, 06 Dec 2013 08:53:55 WARNING  [process:MainProcess, thread:Thread-7] Error in ['python', '-c', "import max_vm_filter; max_vm_filter.max_vms().do_filter(['1ab5d0d9-5f2d-4994-8f6e-773870b1d1a0'], '687e60b6-5632-4c97-80c1-23a63f61c550', {})"] (errno: 1, errors: Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named max_vm_filter
)
Fri, 06 Dec 2013 08:53:55 INFO     [process:MainProcess, thread:Thread-7] [Request:2c9637ac-5e43-11e3-9f2b-001a4a1697fa][Method:run_filters] - returning: []
So if module not exist on rhevm but exist in db, run vms is failed

Comment 10 Jiri Moskovcak 2014-01-22 11:55:41 UTC

*** This bug has been marked as a duplicate of bug 1002444 ***

Comment 11 Artyom 2014-01-22 12:26:31 UTC
Not sure that it's duplicate bugs, because you have different conditions and also different reproduce steps

Comment 12 Doron Fediuck 2014-02-10 13:54:31 UTC
(In reply to Artyom from comment #11)
> Not sure that it's duplicate bugs, because you have different conditions and
> also different reproduce steps

It's a nuance on what causes an empty list using the same backing code.
Not worth monitoring and testing twice since we unify these scenarios now.


Note You need to log in before you can comment on or make changes to this bug.