Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 995836

Summary: [command] remove the use of @LockIdNameAttribute
Product: Red Hat Enterprise Virtualization Manager Reporter: Alon Bar-Lev <alonbl>
Component: ovirt-engineAssignee: Ravi Nori <rnori>
Status: CLOSED CURRENTRELEASE QA Contact: Martin Mucha <mmucha>
Severity: medium Docs Contact:
Priority: unspecified    
Version: unspecifiedCC: bazulay, gklein, iheim, lpeer, oourfali, rbalakri, rgolan, Rhev-m-bugs, yeylon, yzaslavs
Target Milestone: ---Keywords: CodeChange
Target Release: 3.5.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: infra
Fixed In Version: vt1.3 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 997376 (view as bug list) Environment:
Last Closed: 2015-02-17 17:15:06 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: Infra RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 997376, 1142923, 1156165    

Description Alon Bar-Lev 2013-08-11 12:08:15 UTC
Annotations should use behavior modification of reference objects, not as controller of logic paths witin inheritance.

@LockIdNameAttribute annotation is used to indicate incomplete logic requirement.

Each command inherit from CommandBase, and should override the getExclusiveLocks() method to acquire lock.

there is no point in having annotation for the CommandBase to call the getExclusiveLocks() or any other optional feature, as it can have its own embedded default implementations.

Comment 1 Yair Zaslavsky 2013-08-11 13:14:31 UTC
I would like to add that
annotations in java are not inherited .
Since we use inherience in the commands, this is a problem.

The problem exists in other commands - for example in AddDiskCommand.

Comment 2 Yair Zaslavsky 2013-08-11 13:18:48 UTC
Bare in mind that although the keywords, we have issues with current behavior of several commands.
This is why I acked this to 3.3.

Comment 3 Roy Golan 2013-08-11 14:04:49 UTC
grep "getExclusiveLocks" and extract what is missing @LockIdNameAttribute


bll/src/main/java/org/ovirt/engine/core/bll/AddDiskCommand.java
bll/src/main/java/org/ovirt/engine/core/bll/MoveOrCopyDiskCommand.java
bll/src/main/java/org/ovirt/engine/core/bll/RunVmCommandBase.java
bll/src/main/java/org/ovirt/engine/core/bll/AddVdsCommand.java
bll/src/main/java/org/ovirt/engine/core/bll/UpdateVmTemplateCommand.java
bll/src/main/java/org/ovirt/engine/core/bll/ExportRepoImageCommand.java

Comment 4 Roy Golan 2013-08-11 14:12:35 UTC
just to make it clear, the storage commands are calling explicitly aquireLockInternal in the canDoAction. since there is no contract (no interface) we are open to mistakes and misuse. this should be rectified.

Comment 5 Yair Zaslavsky 2013-08-12 12:22:09 UTC
In reply to comment #3 -
Calling aquireLockInternal in CDA can still be risky, IMHO.
If we decide to postpone this from 3.3 - we should fix the above commands.

Comment 7 Yair Zaslavsky 2013-08-19 14:12:49 UTC
ExportRepoImageCommand has the annotation

Comment 8 Yair Zaslavsky 2013-08-19 14:16:16 UTC
It's also in all subclasses of RunVmCommandBase

Comment 9 Eli Mesika 2013-11-08 08:28:55 UTC
*** Bug 997376 has been marked as a duplicate of this bug. ***

Comment 11 Barak 2014-04-10 16:47:31 UTC
This is a bit late to get into 3.4 (2 weeks from RC) and this may be a bit riskey
Hence moving to 3.5

Comment 12 Eyal Edri 2015-02-17 17:15:06 UTC
rhev 3.5.0 was released. closing.