Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 989515

Summary: should wine depend on mesa-dri-drivers.i686?
Product: [Fedora] Fedora Reporter: Sandro Mani <manisandro>
Component: wineAssignee: Andreas Bierfert <andreas.bierfert>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: andreas.bierfert, mike, stefan
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2013-07-29 13:12:44 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Sandro Mani 2013-07-29 12:23:37 UTC
Description of problem:
Installing wine on a x86_64 system does not pull in mesa-dri-drivers.i686.
Running a 32bit windows application which uses DX/GL, wine will say

libGL error: failed to load driver: r600
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
err:winediag:X11DRV_WineGL_InitOpenglInfo Direct rendering is disabled, most likely your 32-bit OpenGL drivers haven't been installed correctly (using GL renderer "Gallium 0.4 on AMD RV620", version "1.4 (3.0 Mesa 9.2.0-devel)").

plus tons of openGL errors.

Possibly wine-core.i686 should depend on mesa-dri-drivers.i686?

Version-Release number of selected component (if applicable):
wine-1.6-2.fc20.x86_64

How reproducible:
always

Comment 1 Michael Cronenworth 2013-07-29 13:12:44 UTC

*** This bug has been marked as a duplicate of bug 827776 ***