Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 959

Summary: /usr/bin/play should use "$@"
Product: [Retired] Red Hat Linux Reporter: jmorzins
Component: soxAssignee: David Lawrence <dkl>
Status: CLOSED WORKSFORME QA Contact:
Severity: low Docs Contact:
Priority: low    
Version: 5.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-03-19 21:50:07 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description jmorzins 1999-01-25 12:05:47 UTC
Red Hat Linux systems ship with a shell script for
/usr/bin/play, which serves as a wrapper around the
/usr/bin/sox program.  The shell script's use of $1
rather than "$@", however, causes /usr/bin/play to reject
any attempts at using command line options.  Since many
programs assume that "play" supports the "-v" option to
set volume, the use of $1 rather than "$@" causes those
programs to produce error messages rather than audio output.
(Exmh, a graphical front-end to the MH mail system shipped
with Red Hat Linux, is one example of a program that tries
to use "play -v" to play .au files.)

The patch included here modifies /usr/bin/play to be
a better imitation of traditional "play" programs.


--- /usr/bin/play       Thu Aug 29 18:38:51 1996
+++ /tmp/play   Mon Jan 25 06:59:45 1999
@@ -1,3 +1,3 @@
 #!/bin/sh

-/usr/bin/sox $1 -t .au - > /dev/audio
+/usr/bin/sox "$@" -t .au - > /dev/audio



(This was reported to me on a system which the author
described as "5.x".  I have verified the bug on a 4.2
system.  "rpm -q -f /usr/bin/play" reports "sox-11g-5".)

Sincerely,
 Jacob Morzinski                      jmorzins@mit.edu

Comment 1 Bill Nottingham 1999-03-19 21:50:59 UTC
using play -v works for me on a 5.9 system.