Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 903

Summary: setsysfont in rc.sysinit messes up vga=2 setting
Product: [Retired] Red Hat Linux Reporter: ecashin <ecashin>
Component: SysVinitAssignee: Bill Nottingham <notting>
Status: CLOSED DUPLICATE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 5.2CC: aleksey, ecashin, rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-01-26 15:08:16 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description ecashin 1999-01-20 21:22:29 UTC
On a fresh RedHat 5.2 install, if the user edits lilo.conf
so that there is a global vga=2 rule and then runs lilo, the
VGA mode will be set to 50 lines per screen.

But in the /etc/rc.d/rc.sysinit script, the block that calls
setsysfont will kick the VGA mode back to 25 lines per
screen.

That wasn't a problem in earlier RedHat releases.

Comment 1 David Lawrence 1999-01-20 23:33:59 UTC
I have verified this to be a problem on a test machine. I added vga=2
to the global settings in lilo.conf and upon rebooting the fonts
changed to the smaller size. The when setsysfont is encountered in the
rc.sysinit the font size is set back up to the default size. It also
exhibits similar behaviour with the ther bga= settings possible.I have verified this to be a problem on a test machine. I added vga=2
to the global settings in lilo.conf and upon rebooting the fonts
changed to the smaller size. The when setsysfont is encountered in the
rc.sysinit the font size is set back up to the default size. It also
exhibits similar behaviour with the ther bga= settings possible.

Comment 2 Aleksey Nogin 1999-01-26 03:13:59 UTC
This is a duplicate of #156This is a duplicate of #156

Comment 3 Jeff Johnson 1999-01-26 15:08:59 UTC
*** This bug has been marked as a duplicate of 156 ***