Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 902

Summary: Real Slow NFS client performance
Product: [Retired] Red Hat Linux Reporter: richard_bach
Component: nfs-serverAssignee: David Lawrence <dkl>
Status: CLOSED NOTABUG QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 5.2CC: aleksey
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-01-20 23:09:57 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description richard_bach 1999-01-20 21:03:39 UTC
Running the iozone program on a nfs mounted volume, linux
client IBM RS6000 as the server, the performance on write
is about 15KB/s for a 10MB file with an 8K buffer size. On
a freebsd 228 system from the same mount point, on the same
network subnet, 10MB/s ethernet, the average is about
800KB/s to 1MB/s. Any other network transfers, ie ftp,
rcp... occur with the expected performance of 700KB/s and
850KB/s. This problem seems to be very localized to the
NFS client implementation.

Comment 1 David Lawrence 1999-01-20 23:09:59 UTC
NFS performance is a kernel issue and is being addressed in the
upcoming new 2.2 kernel versions. We will undoubtly be including 2.2
in upcoming releases.