Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88816

Summary: installing source RPM installs SPEC with wrong name
Product: [Retired] Red Hat Linux Reporter: Scott Sibert <ssibert>
Component: openssl096Assignee: Nalin Dahyabhai <nalin>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: leonard-rh-bugzilla
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard: triage|leonardjo|closed|duplicate
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:52:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Scott Sibert 2003-04-14 15:32:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Installing the source RPM installs the SPEC as openssl.spec instead of 
openssl096.spec.  This actually also is a problem in openssl096b which does 
the same thing of installing its SPEC as openssl.spec instead of 
openssl096b.spec.  If you install all three openssl source packages, the spec 
that exists is from the last RPM installed.  This could lead to confusing 
errors when compiling sources.

Version-Release number of selected component (if applicable):
openssl-0.9.6-15

How reproducible:
Always

Steps to Reproduce:
1. Install openssl096-0.9.6-15.src.rpm
2. Look in /usr/src/redhat/SPECS
3.
    

Actual Results:  openssl.spec

Expected Results:  openssl096.spec

Additional info:

openssl, openssl096 and openssl096b source packages all write their SPEC as 
openssl.spec, thus overwriting each other.

Comment 1 Leonard den Ottolander 2004-11-13 18:25:33 UTC

*** This bug has been marked as a duplicate of 87402 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:40 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.