Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88494

Summary: PXE is broken in Red Hat 9
Product: [Retired] Red Hat Linux Reporter: Alan Cox <alan>
Component: pxeAssignee: Daniel Walsh <dwalsh>
Status: CLOSED WONTFIX QA Contact: Brock Organ <borgan>
Severity: high Docs Contact:
Priority: medium    
Version: 9CC: paulw
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-11 14:46:14 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alan Cox 2003-04-10 15:09:14 UTC
Description of problem:

Update working PXE server from Red Hat 8 to Red Hat 9
Attempt to use PXE

Traces show the PXE daemon receiving multicast messages and ignoring
them. In addition the mtftpd server runs from inetd which means it does not
run until a packet arrives. Since xinetd doesnt know to join the needed 
multicast groups the entire thing doesn't work.

In addition the PXE files license explicitly requires we credit Intel and wait
2 seconds each boot. We don't do this.

I've tcpdumped it for ages, straced it and finally gave up. I replaced the
entire shitpile with pxelinux and the pxelinux recommended pxe daemon
and now it seems to be working ok.

Comment 1 Daniel Walsh 2003-04-11 14:46:14 UTC
We are dropping support for pxe in the RHEL release and will drop it from future 
RedHat release.  I am writing up documentation on how to use dhcp/pxelinux for
X86 platforms.  I am also attempting to document how to do this on other
platforms IPF  and hammer.

Dan