Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88460

Summary: rhl-cg for RH9 does not install if upgrading rhl-cg from RH8.0
Product: [Retired] Red Hat Linux Reporter: Paul <tele0001>
Component: rhl-cgAssignee: Tammy Fox <tammy.c.fox>
Status: CLOSED NOTABUG QA Contact: Tammy Fox <tammy.c.fox>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-20 15:01:55 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul 2003-04-10 09:04:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I was upgrading RH8.0 to RH9 and I had RH8.0 documentation installed.  So, I
could goto RH->Documentation->Customization Guide (CG) to get documentation in
HTML form for RH8.0.  When I used the Documentation disk to install RH9
documentation (via autorun) for the CG, it did not install RH9 CG--it reported
that I already had CG installed.  Yes, I did--but it was RH8.0.  

This was true for each document guide (cg, gsg, maximum rpm, rg, rg, ig) except
for (glossary, sap)-which were not previously installed.  

I also tried rpm -Uvh *.rpm from /mnt/cdrom/RedHat/RPMS/ which is described
under the INSTALL TAB, but that didn't seem to work either.  

Finally, I manually (with rpm) removed each document component (6 in all) and
then re-ran the documentation disk via autorun.  All 8 documents properly
installed RH9 HTML documentation. 

Version-Release number of selected component (if applicable):
rhl-cg-en-9-2

How reproducible:
Always

Steps to Reproduce:
1.Install RH8 documentation via autorun
2. Upgrade from RH8.0 to RH9 
3. Install RH9 documentation via autorun.  The only choices for adding new
documents were SAP and Glossary--both new components.
    

Actual Results:  New RH9 documention was not available in HTML from the
RH->Documentation->Customization Guide menu--RH8.0 CG was there.

Expected Results:  The installation disk should have known that RH8.0
documentation is not RH9 documentation at the very least.  It should have given
me a choice of keeping old documentation or UPGRADING or BOTH.  It did not.  It
kept the older versions.

Additional info:

Comment 1 Tammy Fox 2003-04-14 19:10:19 UTC
Using the command line, I was able to upgrade from the RHL 8.0 Customization
Guide to the RHL 9 Customization Guide:

# rpm -Uvh rhl-cg-en-8.0-2.noarch.rpm
Preparing...                ########################################### [100%]
   1:rhl-cg-en              ########################################### [100%]
# rpm -Uvh rhl-cg-en-9-2.noarch.rpm
Preparing...                ########################################### [100%]
   1:rhl-cg-en              ########################################### [100%]
[root@falcon root]#

It is true that the autorun graphical interface will not let you upgrade to a
newer package, that but is true for any package you have installed, not just
docs. Please file a separate bug against the redhat-config-packages component to
request the ability to upgrade a package already installed from a Red Hat CD-ROM.

What error message are you getting when you try to run the rpm -Uvh command to
upgrade to the RHL 9 rhl-cg-en package?

Comment 2 Tammy Fox 2003-05-20 15:01:55 UTC
Closing due to lack of activity and because I can not reproduce the bug when
trying to install from the command line.