Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88458

Summary: vim hangs
Product: [Retired] Red Hat Linux Reporter: Michael Redinger <michael.redinger>
Component: vimAssignee: Karsten Hopp <karsten>
Status: CLOSED DUPLICATE QA Contact: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: menthos
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:52:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Redinger 2003-04-10 07:52:36 UTC
on some 7.3 and 8.0 systems (actually all I tried) I'm seeing a strange
vi problem that's 100% reproduceable for me:

- open an xterm
- run vi
- close the xterm without exiting vi properly

Now vim immediately uses all of the available CPU. It can only be killed
using kill -9.

It seems that this happens since updating the kernel and glibc.
kernel-2.4.18-27.8.0
glibc-2.3.2-4.80

However, this also happens on some 7.3 systems where I only upgraded
glibc:
glibc-2.2.5-43
kernel-2.4.18-17.7.x

It does not happen on one 7.2 box where I'm still using the old glibc:
glibc-2.2.4-31

It also doesn't happen on a Red Hat 9 system (without glibc updates):
glibc-2.3.2-11.9
kernel-2.4.20-8

It still works fine after updating to glibc-2.3.2-27.9


I then attached to one vim process with strace. I got thousands of lines
like this:

--- SIGSEGV (Segmentation fault) ---


That's quite an issue on multi-user systems ...

Comment 1 Michael Redinger 2003-04-10 07:54:08 UTC
Oh, there's a strace output from Brent Nordquist available:

http://kepler.acns.bethel.edu/~bjn/vim-strace.out


Comment 2 Karsten Hopp 2003-06-20 11:49:01 UTC

*** This bug has been marked as a duplicate of 83700 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:35 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.