Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88271

Summary: sis-651 video card not detected
Product: [Retired] Red Hat Linux Reporter: Bradley <bbaetz>
Component: hwdataAssignee: Brent Fox <bfox>
Status: CLOSED RAWHIDE QA Contact:
Severity: low Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
URL: http://www.winischhofer.net/linuxsisvga.shtml
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-21 21:48:33 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Cards database
none
pcitable data none

Description Bradley 2003-04-08 14:36:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

Description of problem:
SIS-65x graphics cards are supported in XFree-4.3.0, but redhat-config-xfree86
doesn't have that in the list, instead selecting the generic VESA driver when
probing.

I have an SIS-651 card, but the -650 doesn't appear in the list either.

Version-Release number of selected component (if applicable):
redhat-config-xfree86-0.7.3-2

How reproducible:
Always

Steps to Reproduce:
1. Have a machine with an sis-650 family card
2. Run redhat-config-xfree86
3. Configure the video card

Actual Results:  SIS-651 not in the list, and not autoprobed.

Expected Results:  SIS-651 is selectable both manually, and is correctly detected.

Additional info:

See http://www.winischhofer.net/linuxsisvga.shtml for the list of supported cards.

lspci -n gives '01:00.0 Class 0300: 1039:6325', which is '01:00.0 VGA compatible
controller: Silicon Integrated Systems [SiS] SiS650/651/M650/740 PCI/AGP VGA
Display Adapter'

I did an FTP upgrade, so it was in text mode and therefore I don't know if the
graphical installer would have misdetected this too.

Comment 1 Brent Fox 2003-05-21 21:16:09 UTC
What is the output of 'ddcprobe'?  (Must run as root)

Comment 2 Bradley 2003-05-21 21:21:39 UTC
 
Videocard DDC probe results
Description:  Silicon Integrated Systems Corp. 6325
Memory (MB):  16
 
Monitor DDC probe results
ID: GSM430b
Name: StudioWorks
Horizontal Sync (kHZ): 30-70
Vertical Sync (HZ)  : 50-160
Width (mm): 330
Height(mm): 250

Comment 3 Brent Fox 2003-05-21 21:48:33 UTC
Nevermind about the ddcprobe.

The problem was that a change needed to be made to pcitable and a new entry
created in Cards for the SiS 650 card.  Things should work in hwdata-0.81-1,
which should appear in Rawhide in a week or so.  

I don't have this card in house, so I can't test these changes out for sure.  I
would appreciate it if you could test on your machine to see if the
autodetection is fixed now.

Comment 4 Brent Fox 2003-05-21 21:54:02 UTC
Created attachment 91867 [details]
Cards database

Cards database

Comment 5 Brent Fox 2003-05-21 21:54:44 UTC
Created attachment 91868 [details]
pcitable data

Comment 6 Brent Fox 2003-05-21 21:55:25 UTC
Instead of waiting on Rawhide, you could copy those two files I just attached
into /usr/share/hwdata and see if the autodetection works now.

Comment 7 Brent Fox 2003-05-21 21:55:42 UTC
Please reopen this report if that doesn't fix the problem.

Comment 8 Bradley 2003-05-22 10:51:24 UTC
Yep, that works, thanks.