Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88254

Summary: ISO-8859-15 fonts badly handled, empty translations
Product: [Retired] Red Hat Linux Reporter: Stephane Jourdan <stephane.jourdan>
Component: redhat-logviewerAssignee: Tammy Fox <tammy.c.fox>
Status: CLOSED RAWHIDE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-21 19:07:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Stephane Jourdan 2003-04-08 07:57:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
All accentuation from ISO-8859-15 are dropped and stop the display of the reste
of the word. Example : "Connexion de syst�me" becomes "Connexion de syst". 
The same for every word containing an ISO-8859-15 character.

The second problem is the missing translation for the "Preference" tab, and for
the "reload" tab (not bad translation, there is no translation at all).



Version-Release number of selected component (if applicable):
redhat-logviewer-0.8.5-1

How reproducible:
Always

Steps to Reproduce:
1. Launch redhat-logviewer either by the menu or the console in a french 
language-enabled RH9
2. Watch by yourself
3.
    

Additional info:

the following error message keeps going at the startup of redhat-logviewer : 

** (redhat-logviewer.py:3397): WARNING **: Invalid UTF8 string passed to
pango_layout_set_text()

Comment 1 Tammy Fox 2003-04-14 18:10:36 UTC
I am not seeing this problem when I run LANG=fr_FR.UTF-8 redhat-logviewer. Maybe
your translation file (/usr/share/locale/fr/LC_MESSAGES/redhat-logviewer.mo) is
corrupted. Run the command rpm -Va redhat-logviewer to see if the file has been
modified since installation.

Comment 2 Stephane Jourdan 2003-04-15 07:16:02 UTC
Well, rpm -Va redhat-logviewer does not output anything, so I bet nothing has
been modified. 

The translation file is correct with accentuation etc. 

The problem is the display (running LANG=en_US.UTF-8 redhat-logviewer is ok)

Again, it's not a matter of "one install", I did 5 different installations, from
upgrades to clean installs, on different PCs, and each time, same error.

Comment 3 Tammy Fox 2003-04-21 15:37:37 UTC
What happens if you run a different configuration tool such as
redhat-config-users? Do you see the complete translations in it? 

Do you see this problem any where else on your system?

Is it only for the French translations?

Since I see the correct French translations on my machines, I'm thinking it
might not be the redhat-logviewer translations specifically.

Comment 4 Tammy Fox 2003-04-21 19:07:37 UTC
Never mind answering those other questions. I am running the rawhide version,
and that version looks like it displays the French translations fine. The
translation file in version 0.8.5-1 was not in UTF-8 format. Try version 0.8.5-5
from rawhide. It should work fine for you.

Comment 5 Stephane Jourdan 2003-04-22 14:02:00 UTC
Thank you, it's perfect with the version from RawHide !