Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88250

Summary: RPM sometimes hangs
Product: [Retired] Red Hat Linux Reporter: Need Real Name <mal>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED ERRATA QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-14 14:55:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2003-04-08 07:01:32 UTC
RPM sometimes hangs during package upgrade
(rpm -Uvh ...)

rpm can not be killed by ctl-C.
Only by kill -9
Then , after rpm is killed, rpm does not work right. 
I need to reboot the computer to get it working.
Second time the same rpm -Uvh ... command work OK.
I have this with RedHat 8.0. No such problem with RedHat 7.2 or 7.3.
People say (I did not verify this myselft) that such rpm hangs
also occure in RedHat 9.

Comment 1 Jeff Johnson 2003-04-14 14:55:37 UTC
Yes, there's a SIGCHLD missed in rpm-4.1-1.06.

FIxed in rpm-4.1.1, currently available at
    ftp://ftp.rpm.org/pub/rpm/test-4.1.1