Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88238

Summary: "SYSFONT: undefined variable" error when logging in on console
Product: [Retired] Red Hat Linux Reporter: David Baron <dbaron>
Component: initscriptsAssignee: Bill Nottingham <notting>
Status: CLOSED RAWHIDE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: rvokal
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 7.19-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-05-02 19:53:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description David Baron 2003-04-08 03:06:51 UTC
Description of problem:  When I log in on the console, I get the error "SYSFONT:
undefined variable", and my .cshrc and .login files aren't executed.

Version-Release number of selected component (if applicable):
initscripts-7.14-1

How reproducible:  I think reproducing this requires what I have in my
/etc/sysconfig/i18n (which I admit to editing by hand, although to what I think
may have been the default in a clean install of RedHat 8 or 9 rather than an
upgrade).  My /etc/sysconfig/i18n contains:
-----
LANG="en_US.UTF-8"
-----

Steps to Reproduce:
1. Press Ctrl-Left Alt-F1 to get to virtual terminal 1.
2. Log in.
    
Actual results: Error message "SYSFONT: undefined variable", and .cshrc and
.login not executed.

Expected results: No error, .cshrc and .login executed.

Additional info:  The problem seems to be located in /etc/profile.d/lang.csh . 
I fixed it locally with the following change.  (I don't know what this script
was intended to do, so I have no idea if it's right.)

--- /etc/profile.d/lang.csh     2003-03-29 14:15:45.000000000 -0500
+++ /etc/profile.d/lang.csh     2003-04-07 22:56:55.000000000 -0400
@@ -74,10 +74,12 @@
                if ( $?TERM ) then
                    if ( "$TERM" == "linux" ) then
                        if ( `/sbin/consoletype` == "vt" ) then
-                           if ( $?SYSFONTACM ) then
-                               unicode_start $SYSFONT $SYSFONTACM
-                           else
-                               unicode_start $SYSFONT
+                           if ( $?SYSFONT ) then
+                               if ( $?SYSFONTACM ) then
+                                   unicode_start $SYSFONT $SYSFONTACM
+                               else
+                                   unicode_start $SYSFONT
+                               endif
                            endif
                        endif
                    endif

Comment 1 Bill Nottingham 2003-05-02 19:53:36 UTC
Fixed in 7.19-1 or so.