Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88175

Summary: Include ghostscript shared library
Product: [Retired] Red Hat Raw Hide Reporter: Rex Dieter <rdieter>
Component: ghostscriptAssignee: Tim Waugh <twaugh>
Status: CLOSED RAWHIDE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: gsview, jgiglio, jrb, nphilipp
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: 7.07-18 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-01-20 16:34:56 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 113951    

Description Rex Dieter 2003-04-07 12:16:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Please reconsider including the ghostscript shared library/object.  I (and my 
users) find it very useful, and it can be used in many other packages, 
including ImageMagick and gsview (though currently not included in redhat).

Version-Release number of selected component (if applicable):
7.05-32

Comment 1 Rex Dieter 2003-04-07 12:33:01 UTC
At *least* change the
Obsoletes: ghostscript-gtk
to
Obsoletes: ghostscript-gtk < %{version}-%{release}
so that you can have the option of putting it back later.

Comment 2 Tim Waugh 2003-04-07 12:49:20 UTC
It can be used in ImageMagick?

Comment 3 Rex Dieter 2003-04-07 12:54:17 UTC
Yep, ImageMagick can link to it and call it this way (faster) instead of using 
the external gs binary for any eps/ps conversions.

Comment 4 Tim Waugh 2003-04-07 12:57:08 UTC
jrb: let me know if you want to do this.  Sounds a good idea actually.

Comment 5 Rex Dieter 2003-04-07 12:59:51 UTC
References:

http://studio.imagemagick.org/pipermail/magick-developers/2002-April/000495.html

and
http://studio.imagemagick.org/www/install.html
(the paragraph starting with)
Ghostscript (release 7.0 and later) may optionally install a library (libgs). 
If this library is installed, ImageMagick may be configured to use it.


Comment 6 Jonathan Blandford 2003-04-07 16:23:55 UTC
Schweet.  I'll have to look into that for the next release.

Comment 7 Tim Waugh 2003-04-07 16:55:53 UTC
The spec file in CVS has %{build_libgs} parametrized, when you want to play.

Probably the shared object should go in a separate subpackage though.

Comment 8 Stephen McGreal 2003-05-02 13:35:31 UTC
I'd like to add my desire to have a rebuilt ghostscript package for RH9, which 
includes the libgs.so shared library.  I have been trying to get GSView 4.4 to 
work and apparently it can't due to this missing library.

Thanks

Comment 9 Rex Dieter 2003-05-21 16:59:23 UTC
And, FYI, in order to build ImageMagick w/ghostscript shared-lib support, it looks 
for ghostscript's headers in  
%{_includedir}/ps 
by default.  You'll either need to put a symlink 
%{_includedir}/ps -> %{_includedir}/ghostscript 
in the ghostscript pkg or patch ImageMagick to look in %{_includedir}/ghostscript 

Comment 10 Gigs 2003-08-27 20:38:51 UTC
I would also like to see this included in a Red Hat 9 update package.  I am also
trying to get gsview to work with Red Hat 9, and now I have to recompile
ghostscript, which is not trivial if I want to retain all the drivers that come
with the RH ghostscript.

Comment 14 Russell Lang 2003-10-10 04:14:34 UTC
Please include libgs.so.  This is also required by GSview,
another PostScript/PDF viewer.


Comment 15 Gigs 2003-10-10 23:09:13 UTC
I'm confused, libgs.so was included with Red Hat 8.0, but not 9?  Is this a
mistake or a deliberate choice?  If it's a mistake then maybe we should escalate
this bug higher than enhancement level.

Comment 16 Tim Waugh 2003-10-11 10:43:26 UTC
Space was tight, and nothing we shipped used it.

I think we'll have to reevaluate this next time round.

Comment 17 Rex Dieter 2004-01-20 15:59:39 UTC
Please, please, pretty please re-enable libgs.so support for Fedora
Core (2).

To reiterate, several software packages, including ImageMagick (and
gsview) can take advantage of this feature.

Comment 18 Tim Waugh 2004-01-20 16:34:56 UTC
I'm building a 7.07-18 now which has this turned back on.

Comment 19 Rex Dieter 2004-01-20 16:39:00 UTC
Thank you!