Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88138

Summary: swap on exluded disk still mkswap'ed
Product: [Retired] Red Hat Linux Reporter: Paul Wouters <paul>
Component: anacondaAssignee: Jeremy Katz <katzj>
Status: CLOSED CURRENTRELEASE QA Contact: Mike McLean <mikem>
Severity: medium Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-05 03:08:25 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Paul Wouters 2003-04-06 15:49:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
When installing with two disks with redhat installs on the, and 
performing a "fresh install" (no upgrade) on hda using autopartition,
hdb shows up with the current partitions on it, though without mountpoints. This
is confusing since it seems to suggest these will
be installed/created as well.
When I continued, it actually warned that hdb3 (a swap partition) is
going to get destroyed. It then also (I believe) mkswap'ed it.

I think disks that have been explicitely excluded should not show up
in any partitioning selection later on, and should also not be touched
by mkswap.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Steps to Reproduce:
1.put two disk with redhat isntallations in a machine
2. install redhat on disk 1


Additional info:

Comment 1 Stan Bubrouski 2003-07-01 01:26:06 UTC
This is not limited to happening on /dev/hda, I did custom on
a fresh install and disk druid selected two partitions on my
/dev/hdc as being of them was an old 20 GB Ext2
partition.  But it gets worse, I edited those partions and
selected the Do Not Touch This Partition option or whatever
and Disk Druid unchecked them as partions to be formatted.  I
proceeded to setup my partition configuration on /dev/hdb,
but when it came time to install the packages I got an error
about how it could not modify /dev/hdc5 (it tried to mkswap my
two other partions on /dev/hdc even though I removed those
from Disk Druid (I thought).  It then told me to click OK and
reboot... this is not how it is suppost to be...I cannot install
RH9 atm.

Comment 2 Stan Bubrouski 2003-07-01 01:27:08 UTC
Oh i forgot to mention I was installing on /dev/hdb and it still
tried to create swap partions on /dev/hdc just to clear up my
merky description.

Comment 3 Jeremy Katz 2004-10-05 03:08:25 UTC
This has been changedin recent releases.