Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88106

Summary: open with fail
Product: [Retired] Red Hat Linux Reporter: bugzilla <kurtschwartz>
Component: nautilusAssignee: Alexander Larsson <alexl>
Status: CLOSED RAWHIDE QA Contact: Jay Turner <jturner>
Severity: medium Docs Contact:
Priority: high    
Version: 9CC: alfre, bug_rh, dch, err, srevivo, steveng, techtuff, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-10-04 13:24:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description bugzilla 2003-04-05 19:23:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Nautilus 'open with' functionality not working.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Select any file and right mouse.
2. Select 'open with' and an application.  (Tried: gedit, GNU Emacs and vi).

This is repeatable regardless of user (including root) and folder or file.    

Actual Results:  Nothing happens...


Expected Results:  File would open in the specified program

Additional info:

Comment 1 Warren Togami 2003-04-06 04:42:32 UTC
Works for me.  Did you do a fresh install, or upgrade?  If upgrade, from which
RHL version?


Comment 2 bugzilla 2003-04-06 23:19:30 UTC
Fresh install...  formatted the drives prior to install.  If it helps, it's 
Red Hat version 9 and Nautilus version 2.2.1.  I've tried logging in as root 
and opening files in the root folder (install.log) and a variety of other 
combinations.  Unfortunately, nothing works.  The only way to launch gedit to 
modify the file is from a terminal session.


Comment 3 Alexander Larsson 2003-04-07 10:00:09 UTC
*** Bug 88141 has been marked as a duplicate of this bug. ***

Comment 4 Alexander Larsson 2003-04-07 10:06:50 UTC
When this happens, do you get anything added to ~/.xsession-errors?


Comment 5 Alfredo 2003-04-08 10:26:23 UTC
I have the same problem after upgrade from 8 to 9. The contents of my
.xsession-errors:

SESSION_MANAGER=local/bubu:/tmp/.ICE-unix/859
Gnome-Message: gnome_execute_async_with_env_fds: returning -1
Gnome-Message: gnome_execute_async_with_env_fds: returning -1
Gnome-Message: gnome_execute_async_with_env_fds: returning -1
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document
Extra content at the end of the document


Comment 6 Mike Vanecek 2003-04-08 17:17:03 UTC
I am getting the same errors after RH8 to RH9. I am in the process of 
rebuilding from scratch. I did find that the problem was somewhat intermittant 
but was not able to quite figure out the pattern. If I click open, information, 
and select edit with gedit it will open gedit. After that, the right mouse 
seems to work. Close nautilus, and the same pattern starts. I see the exact 
same pattern with nautilus-script that has gedit command. Doing a right click 
gedit on a script file tends to not work more often. However, sometimes right 
click on a text file will work and then after that script files will work 
(during that nautilus session). I will report more information after the 
rebuild from scratch.


Comment 7 Alexander Larsson 2003-04-11 13:40:20 UTC
Hmmm. The "Gnome-Message: gnome_execute_async_with_env_fds: returning -1" look
interesting. Does anyone else get those? It means spawning the child failed somehow.


Comment 8 Mike Vanecek 2003-04-15 17:11:36 UTC
I did before. Unfortunately for debugging, Nautilus is working just as it
should. Hard as I tried, it would not fail to open a file.

Of course, up2date has updated a bunch of items since the original report. I
also deleted the .xsession-error file to ensure that I captured the most recent
errors. None have yet occurred.

I will monitor and report back if they pop up again.

Comment 9 Alex Deucher 2003-05-02 14:43:24 UTC
Just as a datapoint, I'm seeing a similar thing.  stock Redhat 9. Nautilus "open
with" menu works as long as nautilus is in Icon view mode.  if I switch to list
view, then "open with" no longer works.

Comment 10 Alexander Larsson 2003-05-05 06:08:51 UTC
Comments I got via an email:

I have a fresh install of Red Hat 9 + errata that is exhibiting the 
symptoms described in this bug.  Interestingly,  "Open With" appears to 
work OK in the icon view but fails consistently in the list view.  In 
the list view it can sometimes be coerced into working with a reload. 
"Open" (either from menu or double click) works consistently.

Nothing appears to be written to .xsession-errors when this failure 
occurs.  Problem occurs as root and normal user and does not seem to be 
affected by type of file (text, media, graphic, etc).

Comment 11 Alexander Larsson 2003-05-05 06:13:58 UTC
I'm finally able to reproduce this. It apparently only happens in the listview.
However, it doesn't seem to be happening in my build from CVS. There has been
some changes to this area recently that might affect this though.

Comment 12 Alexander Larsson 2003-05-19 09:22:34 UTC
*** Bug 91076 has been marked as a duplicate of this bug. ***

Comment 13 Alexander Larsson 2003-09-05 10:08:09 UTC
*** Bug 103631 has been marked as a duplicate of this bug. ***

Comment 14 Stephen Ng 2003-10-12 03:26:07 UTC
I have encountered the same problem and I can confirm that the problem only 
seems to happen on list view but not on icon view.

Comment 15 Alexander Larsson 2004-10-04 13:24:27 UTC
This is likely fixed in rawhide, which has the changes mentioned
above, plus a total redoing of open-with functionallity.