Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88085

Summary: top reports 0% iowait even when disk heavily used
Product: [Retired] Red Hat Linux Reporter: Michael Young <m.a.young>
Component: procpsAssignee: Alexander Larsson <alexl>
Status: CLOSED DEFERRED QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: anielsen, riel, wtogami
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-08-05 09:13:22 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Michael Young 2003-04-05 12:02:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The iowait field in top seems to be stuck at 0.0% even when the machine is under
heavy hard disk load. It looks like what should be reported as iowait is instead
included in the idle figure.

Comment 1 Alexander Larsson 2003-04-07 10:11:44 UTC
Looking at the code it seems top reads the iowait data from the fifth numeric
filed in the /proc/stat cpu line.

However, that field doesn't seem to exist. What's up with this?

Comment 2 Alexander Larsson 2003-04-07 10:15:50 UTC
Ah, this is apparently a 2.5.x kernel extension....


Comment 3 Rik van Riel 2003-07-14 12:45:48 UTC
indeed, iowait statistics is something in the 2.5 kernel (and RHEL)

it is not present in the standard 2.4 kernel

Comment 4 Alexander Larsson 2003-08-05 09:13:22 UTC
So, this will be fixed when we move to 2.6.


Comment 5 Michael Young 2003-08-05 10:03:57 UTC
Yes, indeed it does work if you boot with arjan's test 2.6 kernels.