Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 88054

Summary: typoes in /etc/init.d/pcmcia startup script
Product: [Fedora] Fedora Reporter: Robert P. J. Day <rpjday>
Component: pcmcia-csAssignee: Arjan van de Ven <arjanv>
Status: CLOSED DUPLICATE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 2CC: dave.miles, gczarcinski, go, ivo, jroyse
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:52:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 109188    

Description Robert P. J. Day 2003-04-04 22:30:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
  lines 107-9 in /etc/init.d/pcmcia script, set of modprobe
commands, have arguments that end with ".o".  this is not
possible -- modprobe only takes the module name, not the 
file name.

  this will cause loading of any newly-built kernels to fail
to load the pcmcia modules.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. build a new kernel with pcmcia functionality
2. boot to new kernel
3.
    

Actual Results:    pcmcia modules are not loaded

Expected Results:    pcmcia modules should load

Additional info:

  just get rid of the ".o" suffixes

Comment 1 Ivo Sarak 2003-04-07 16:30:07 UTC
Maybe that is why there is a bug:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81282

Comment 2 Josiah Royse 2003-04-29 18:56:43 UTC
Here's where the directory that fools the /etc/init.d/pcmcia script comes from.

A quick fix: After you build a new kernel and reboot- type "rm -rf
/lib/modules/`uname -r`/pcmcia"  this directory is just full of symlinks.

/usr/src/linux-2.4/Makefile:
------------------
# Backwards compatibilty symlinks for people still using old versions
# of pcmcia-cs with hard coded pathnames on insmod.  Remove
# _modinst_post_pcmcia for kernel 2.4.1.
.PHONY: _modinst_post_pcmcia
_modinst_post_pcmcia:
        cd $(MODLIB); \
        mkdir -p pcmcia; \
        find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{} pcmcia


Comment 3 Miloslav Trmac 2004-02-10 17:25:47 UTC
*** Bug 112333 has been marked as a duplicate of this bug. ***

Comment 4 Josiah Royse 2004-02-10 17:36:11 UTC
This appears to be a duplicate of Bug 81282  -- which is closed.

Comment 5 Jaap Haitsma 2004-02-24 17:23:00 UTC
Latest update of kernel-pcmcia-cs-3.1.31-16 for Fedora core has the 3
".o"s removed. This bug can be closed

Comment 6 Alexandre Oliva 2004-06-22 12:49:59 UTC
pcmcia-cs-3.2.7-1.5 still has .o extensions in these lines:
                /sbin/insmod $PC/pcmcia_core.o $CORE_OPTS
                /sbin/insmod $PC/$PCIC.o $PCIC_OPTS
                /sbin/insmod $PC/ds.o


Comment 7 Bill Nottingham 2004-09-08 06:51:39 UTC
That's with insmod, which takes full pathnames.

*** This bug has been marked as a duplicate of 81282 ***

Comment 8 Bill Nottingham 2004-09-08 06:55:16 UTC
*** Bug 97751 has been marked as a duplicate of this bug. ***

Comment 9 Red Hat Bugzilla 2006-02-21 18:52:29 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.