Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 87849

Summary: Additional PLATYPUS vendor line for scsi_scan.c
Product: Red Hat Enterprise Linux 2.1 Reporter: Peter Miller <peterm>
Component: kernelAssignee: Tom Coughlan <coughlan>
Status: CLOSED CURRENTRELEASE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 2.1CC: shillman
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-10-03 15:08:35 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Attachments:
Description Flags
Additional PLATYPUS vendor line. none

Description Peter Miller 2003-04-03 04:30:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
RedHat Advanced Server 2.1

I work for Platypus Technology.  We make solid state storage devices.
Our testing indicates that an additional vendor line is required in 
drives.scsi/scsi_scan.c, a patch is attached.

Without this patch, "scsi: DISK CAPACITY: failure" error messages frequently 
occur when attempting to access Platypus QikLINK fibre channel devices.

Version-Release number of selected component (if applicable):
kernel-2.4.9-e.3
kernel-smp-2.4.9-e.3
kernel-source-2.4.9-e.3

How reproducible:
Always

Steps to Reproduce:
1. install Platypus QikLINK product
2. without the patch, attempt to load you fibre channel device driver module
3. examine /var/log/messages, you will see the error "scsi: DISK CAPACITY: 
failure" message
    

Expected Results:  No error should appear.
All LUNS should be reported by
cat /proc/scsi/scsi

Additional info:

Patch:
--- drivers/scsi/scsi_scan.c-orig       Wed Mar 26 11:26:18 2003
+++ drivers/scsi/scsi_scan.c    Wed Mar 26 11:27:53 2003
@@ -167,6 +167,7 @@
        {"IBM","AuSaV1S2", "*", BLIST_FORCELUN},
        {"IBM","3542", "*", BLIST_FORCELUN},
        {"DELL","PV-136T-FC", "*", BLIST_FORCELUN},
+       {"PLATYPUS", "CX5", "*", BLIST_SPARSELUN | BLIST_FORCELUN},

        /*
         * Must be at end of list...

Comment 1 Peter Miller 2003-04-03 04:34:22 UTC
Created attachment 90859 [details]
Additional PLATYPUS vendor line.

Comment 2 Arjan van de Ven 2003-04-03 13:55:59 UTC
I'm passing this request on to our storage specialist for adding to the sourcebase. 

Comment 3 Tom Coughlan 2003-04-09 20:02:55 UTC
This has been checked in for RHEL 2.1, x86 and ia64.

(Based on the kernel version you running, I see you are running RHEL 2.1, not
RHL 8.0)

I also submitted this to Marcelo and Alan, so all future kernels should have it.  

Comment 4 Tom Coughlan 2003-07-23 18:13:08 UTC
*** Bug 87850 has been marked as a duplicate of this bug. ***

Comment 5 Suzanne Hillman 2003-10-03 15:08:35 UTC
Since it's been almost 6 months since the patch was checked in, with no comments
saying that it was not actually fixed, I'm closing this. Please reopen if the
problem still exists.