Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 87796

Summary: Can't play sounds using arts : /usr/lib/libartscbackend.la missing
Product: [Retired] Red Hat Linux Reporter: Need Real Name <vuksan>
Component: artsAssignee: Ngo Than <than>
Status: CLOSED UPSTREAM QA Contact:
Severity: high Docs Contact:
Priority: medium    
Version: 9   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-04-03 15:33:36 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Need Real Name 2003-04-02 16:53:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
This is a completely new install of Redhat 9. I am using KDE. 
XMMS Output plug-in is set to aRTS driver 0.4 (libartsout.so). I start xmms
click Play and I get

arts_init error: loading the aRts backend "/usr/lib/libartscbackend.la" failed

I looked around the file system and there is no such file :-(.

I also tried running 

artsdsp realplay 

which used to work under 8.0 freezes up when the GUI comes up. I ran 

strace artsdsp realplay 

and I get

open("/usr/lib/libartscbackend.la", O_RDONLY) = -1 ENOENT (No such file or
directory)
close(10)                               = 0
open("/dev/dsp", O_WRONLY <unfinished ...>

It waits forever on the last statement.

Version-Release number of selected component (if applicable):
arts-1.1-7

How reproducible:
Always

Steps to Reproduce:
 

Additional info:

Comment 1 Ngo Than 2003-04-03 15:33:36 UTC
it's fixed in KDE 3.1.1, which you can download from ftp.kde.org.