Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 87768

Summary: 'man fontconfig' gives iconv error
Product: [Retired] Red Hat Linux Reporter: Mark van Rossum <mvanross>
Component: manAssignee: Eido Inoue <havill>
Status: CLOSED RAWHIDE QA Contact: Ben Levenson <benl>
Severity: low Docs Contact:
Priority: medium    
Version: 9CC: chris
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: 1.58-1 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-08-08 16:32:20 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Mark van Rossum 2003-04-02 08:48:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When I type 'man fontconfig'
I get
Iconv: illegal input sequence at position 214
This happens for some man pages, not for others (man ls is fine)

Version-Release number of selected component (if applicable):
rh 9.0

How reproducible:
Always

Steps to Reproduce:
1.see above
2.
3.
    

Additional info:

Iconv incomplete ?

Comment 1 Mark van Rossum 2003-04-02 14:17:31 UTC
This bug does not seem to involve an unsupported IDE chipset,
as hdparm -t /dev/hda 
returns normal values.

Quick fix: 
Go back to older kernel
rpm -ivh --oldpackage kernel-2.4.18-27.8.0.i686.rpm


Comment 2 Mark van Rossum 2003-04-02 14:20:42 UTC
Sorry previous additional comment was meant for other bug.
Please ignore.


Comment 3 Christopher Wong 2003-04-22 15:34:52 UTC
Oddly enough, running "man:fontconfig" in KDE -- using Konqueror as man page 
viewer -- displays the fontconfig manpage just fine.

Comment 4 Owen Taylor 2003-06-10 22:08:27 UTC
fontconfig man page is gone as of fontconfig-2.2.1. Reassigning to 
man since it looks like 'fontconfig' was just an example of the
problem.

Comment 5 Eido Inoue 2003-08-08 16:32:20 UTC
man-pages version 1.58-1 seems to have fixed the iconv problems that have been
reported.

Comment 6 Łukasz Trąbiński 2003-10-25 16:03:08 UTC
[lukasz@lt lukasz]$ rpm -q man
man-1.5k-6

When we try type `man 2 umask`
iconv: illegal input sequence at position 1518

man from redhat/rawhide man-1.5k-12 is OK.