Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 87760

Summary: "sizing" cursor looks like space ship ("trek")
Product: [Retired] Red Hat Linux Reporter: Jeff Epler <jepler>
Component: redhat-artworkAssignee: Alexander Larsson <alexl>
Status: CLOSED DUPLICATE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 9CC: garrett, mharris
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:52:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Jeff Epler 2003-04-02 03:47:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.8 (X11; Linux i686; U;) Gecko/20030212

Description of problem:
When an application selects the "sizing" cursor, an image of a space ship is
displayed instead.



Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always

Steps to Reproduce:
1. $ wish
2. % . configure -cursor sizing
3. move mouse pointer into wish window
    

Actual Results:  An image of a space-ship is displayed (the same as the "trek"
cursor)

Expected Results:  An image resembling the original "sizing" cursor should be
displayed (a box with an arrow descending to the right, and an inverted L above
to the left)

Additional info:

Comment 1 Bill Nottingham 2003-04-02 04:18:54 UTC
Yeah, it's in the wrong slot.

Comment 2 Alexander Larsson 2003-08-06 09:17:03 UTC
Garrett, can you take a look at this. I don't see a resize cursor in the redhat
ones.

Comment 3 Alexander Larsson 2003-08-06 09:34:13 UTC
Possibly related to 85422

Comment 4 Jeff Epler 2003-08-06 14:50:53 UTC
The "sizing" cursor certainly seems to come from the bluecurve theme:
$ rpm -qf /usr/share/icons/Bluecurve/cursors/sizing 
redhat-artwork-0.73-1
$ cat /etc/redhat-release
Red Hat Linux release 9 (Shrike)

Moreover, "wish" clearly opens that file when configured for the sizing cursor
(spaceship on my system):
$ echo ". configure -cursor sizing" | strace -e open wish 2>&1 | grep
Bluecurve/cursors
open("/net/filesrv1/sd3a/users/jepler/.icons/Bluecurve/cursors/sizing",
O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/icons/Bluecurve/cursors/sizing", O_RDONLY) = 4

However, the "sizing" and "trek" cursors aren't actually identical:
$ md5sum /usr/share/icons/Bluecurve/cursors/{sizing,trek}
0f76b0285cb1da2794ae3699ab1961e1  /usr/share/icons/Bluecurve/cursors/sizing
836d5e12394370959b18a9c97377d44c  /usr/share/icons/Bluecurve/cursors/trek


Comment 5 Alexander Larsson 2003-08-08 13:27:39 UTC

*** This bug has been marked as a duplicate of 85422 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:52:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.