Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 87596

Summary: Can't categorize CIs; lack permission
Product: [Retired] Red Hat Enterprise CMS Reporter: Jon Orris <jorris>
Component: otherAssignee: Justin Ross <jross>
Status: CLOSED RAWHIDE QA Contact: Jon Orris <jorris>
Severity: medium Docs Contact:
Priority: medium    
Version: nightlyCC: ccm-bugs-list, sseago
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-06-03 21:24:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 88926    

Description Jon Orris 2003-03-29 20:06:48 UTC
@29175 Postgres
Description of problem:
The author of a content item cannot categorize it. Get a message saying: 
'Need categorize items privilege on that category'

Several CMS tests assign items to categories & test published article
categorization.

Comment 1 Justin Ross 2003-05-27 15:37:22 UTC
I need some guidance on this one.  The category permission checks on tip are the
same as those that existed when I started making UI changes.

So, what is the *expected* behavior?  Should an item author automatically get
the categorize-items privilege?  Scott, I added you since you mentioned
something about changes to permissions in categorization.

Comment 2 Scott Seago 2003-05-27 15:45:26 UTC
I _think_ the right thing here would be to grant the author the "Categorize
items"  privilege. I don't know what the exact use case for this is, but I
expect it would be something like "We have 100 authors, but only some of them
have the privilege to categorize items -- items authored by those other authors
will have to be categorized at the approval step" or something like that. In any
case, if granting the author (or the author's role) that privilege solves the
problem, then it sounds like the system is working as intended.

Comment 3 Justin Ross 2003-06-03 19:29:05 UTC
Fixed in perforce 31973 by adding the categorize_items privilege to the Author
role in CMS's enterprise.init.in.