Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 87484

Summary: No error message when X11 startup fails
Product: [Retired] Red Hat Linux Reporter: Toralf <bugzilla>
Component: gdmAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED CURRENTRELEASE QA Contact: Mike McLean <mikem>
Severity: low Docs Contact:
Priority: low    
Version: 7.3Keywords: MoveUpstream, Triaged
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-11-05 03:10:37 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Toralf 2003-03-27 16:01:40 UTC
Description of problem:
No error message is given, when the system in general (as oppsed to the X server
config) has some kind of problem that prevents the X server from starting. This
is for instance the case when the root file system is full or there is something
wrong with the network setup.

Version-Release number of selected component (if applicable):
2.2.3.1-22

How reproducible:
Everytime.

Steps to Reproduce:
1. Fill up the system disk
2. Reboot
    
Actual results:
The system pretends that it is configured for text-mode only, and that
everything is otherwise fine.

Expected results:
Error message

Comment 1 Havoc Pennington 2003-07-30 21:27:28 UTC
I'm not sure I understand exactly what you mean; does the system get to the 
part where it tries to start the X server? does gdm start? at what point 
are you saying the failure occurs?

Comment 2 Toralf 2003-07-31 11:27:01 UTC
I'm not in my office now so I can't check any details, but essentially what 
happens is that after a reboot, it looks like the system has (successfully) 
entered runlevel 3, but closer inspection reveals that it's actually in 
runlevel 5, but X just hasn't started - and I can't find anything wrong with 
inittab or similar. 

Happens on Red Hat 9, too; we have an old laptop that ended up in this state 
after upgrade to version 9 (and I never bothered to fix it as it's not really 
being used anymore.)

It looks like you may get this kind of behaviour when X fails due to a problem 
with the general system setup, as opposed to an XFree86 config error. One 
example of such a problem is an incorrect network configuration; maybe you'll 
see what I mean if you remove the localhost entry from /etc/hosts. 

Comment 3 Ray Strode [halfline] 2004-11-05 03:10:37 UTC
GDM reports when X fails to start now.