Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 86611

Summary: Wrong description for PUBLISH_SOURCE (publish-to-fs-source) in com.arsdigita.cms.publishToFile.Initializer.java
Product: [Retired] Red Hat Enterprise CMS Reporter: Christine VACHER <cvacher>
Component: documentationAssignee: ccm-bugs-list
Status: CLOSED DUPLICATE QA Contact: Jon Orris <jorris>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-03-26 14:42:53 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Christine VACHER 2003-03-26 14:37:51 UTC
Description for PUBLISH_SOURCE in
com.arsdigita.cms.publishToFile.Initializer.java reads:
PUBLISH_SOURCE, "The base and port that must appear after 'localhost' to allow
reading " +"content to be published.  Example: If source of published items are
read at " +"'http://localhost:8713/acs' the PublishSource would be '8713/acs'"

A value of "8713/acs" does not work.
com.arsdigita.cms.publishToFile.PublishToFile.java requires a valid URL ending
with '/':
throw new InitializationException("Invalid URL specified for publishSource. " +"
Must be like: 'http://localhost:port/base', " +
(...)
throw new InitializationException("PublishSource sourceBase must end in '/'");

Comment 1 Christine VACHER 2003-03-26 14:42:24 UTC

*** This bug has been marked as a duplicate of 86614 ***