Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 86398

Summary: Informix crashed after upgrade to glibc-2.3.2-4.80
Product: [Retired] Red Hat Linux Reporter: sretr
Component: glibcAssignee: Jakub Jelinek <jakub>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: high Docs Contact:
Priority: medium    
Version: 8.0CC: fweimer, mitr
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:52:15 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description sretr 2003-03-21 11:58:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.2.1) Gecko/20021130

Description of problem:
Informix crash immediately after start.

With glibc-2.2.93-5 informix run fine, crash only if I connect to db over
network and ip address isn't in /etc/hosts ( same problem like with mysql ).


Version-Release number of selected component (if applicable):
glibc-2.3.2-4.80

How reproducible:
Always

Steps to Reproduce:
1. upgrate to glibc-2.3.2-4.80
2. restart informix
3.
    

Actual Results:  Informix crash immediately after start

Expected Results:  Informix should run without any problem

Additional info:

strace return this

[pid   893] umask(07)                   = 03
[pid   893] time([1048145291])          = 1048145291
[pid   893] write(5, "08:28:11  ", 10)  = 10
[pid   893] write(5, "Loading Module <BUILTINNULL>", 28) = 28
[pid   893] write(5, "\n", 1)           = 1
[pid   893] rt_sigprocmask(SIG_UNBLOCK, [CONT], NULL, 8) = 0
[pid   893] rt_sigprocmask(SIG_UNBLOCK, [ALRM], NULL, 8) = 0
[pid   893] close(5)                    = 0
[pid   893] rt_sigprocmask(SIG_BLOCK, [ALRM], NULL, 8) = 0
[pid   893] alarm(0)                    = 1
[pid   893] rt_sigaction(SIGALRM, {SIG_IGN}, {0x4002b250, [QUIT ILL ABRT USR1
SEGV 33 37 38 39 40 41 44 45 46 48 49 52 60], SA_RESTORER|SA_SIGINFO,
0x400ec560}, 8) = 0
[pid   893] rt_sigprocmask(SIG_UNBLOCK, [ALRM], NULL, 8) = 0
[pid   893] rt_sigaction(SIGALRM, {SIG_DFL}, {SIG_IGN}, 8) = 0
[pid   893] semctl(327680, 1, SETVAL, 0xbffddca0) = 0
[pid   893] rt_sigprocmask(SIG_BLOCK, [ALRM], NULL, 8) = 0
[pid   893] --- SIGSEGV (Segmentation fault) ---
<... wait4 resumed> NULL, 0, NULL)      = -1 ECHILD (No child processes)
_exit(1)                                = ?

Comment 1 sretr 2003-03-24 15:18:50 UTC
I found that informix crash bear on bug 86359.
I installed older glibc-2.2.93-5 library (
ld-linux.so.2,libcrypt.so.1,libc.so.6, libdl.so.2,libm.so.6,libpthread.so.0 ) to
/opt/informix/lib. 
When I type 
/lib/ld-linux.so.2 --list --library-path /opt/informix/lib
/opt/informix/ids-9.30.UC2E3/bin/oninit
than a I get this
        iosm09a.so => /usr/lib/iosm09a.so (0x40007000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x4000a000)
        ismdd09a.so => /usr/lib/ismdd09a.so (0x4005c000)
        libm.so.6 => /lib/libm.so.6 (0x4005e000)
        libdl.so.2 => /opt/informix/lib/libdl.so.2 (0x40080000)
        libcrypt.so.1 => /opt/informix/lib/libcrypt.so.1 (0x40083000)
        libc.so.6 => /lib/libc.so.6 (0x400b0000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
When I type 
/opt/informix/lib/ld-linux.so.2 --list --library-path /opt/informix/lib
/opt/informix/ids-9.30.UC2E3/bin/oninit
than a I get this
        iosm09a.so => /usr/lib/iosm09a.so (0x40007000)
        libpthread.so.0 => /opt/informix/lib/libpthread.so.0 (0x4000a000)
        ismdd09a.so => /usr/lib/ismdd09a.so (0x4003a000)
        libm.so.6 => /opt/informix/lib/libm.so.6 (0x4003c000)
        libdl.so.2 => /opt/informix/lib/libdl.so.2 (0x4005e000)
        libcrypt.so.1 => /opt/informix/lib/libcrypt.so.1 (0x40061000)
        libc.so.6 => /opt/informix/lib/libc.so.6 (0x42000000)
        /lib/ld-linux.so.2 => /opt/informix/lib/ld-linux.so.2 (0x80000000)

It seems that is something wrong with dynamic linker which try to load libc,
libm and libpthread only from directory /lib.


Comment 2 Jakub Jelinek 2003-03-24 15:39:27 UTC

*** This bug has been marked as a duplicate of 86359 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.