Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 86244

Summary: glibc-kernheaders do not include msr.h, delay.h
Product: [Retired] Red Hat Linux Reporter: Allan Masri <allanm051>
Component: glibc-kernheadersAssignee: Arjan van de Ven <arjanv>
Status: CLOSED NOTABUG QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.3CC: adler, nafiton, zhangq
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-03-18 09:07:21 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Allan Masri 2003-03-18 01:18:42 UTC
Description of problem:
This problem is still the same as 65076. These headers are used in Trendnet's
Ethernet Card drivers. It is possible trendnet's engineers are compiling against
older versions of Red Hat Linux. I stress that I am not writing these drivers,
just trying to compile them so I can use the cards. Admittedly, the problem may
be trendnet's, but I would like to find copies of these two files, if anyone can
find them and attach them to this bug.

Yes, I understand these files should not be included in the compiler
distribution, but that doesn't help me. I repeat, these files do not exist in my
glibc-kernheaders.rpm, nor anywhere else in my Red Hat Linux 7.3 distribution.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1.compile Trendnet's driver for its ethernet card TE100-PCIWA|WN.
2.compilation fails
    
Actual results:
compiler complains that it can't find kernheaders, asm/msr.h, and asm/delay.h

Expected results:
compiler creates driver, permitting me to use ethernet card

Additional info:

Comment 1 Arjan van de Ven 2003-03-18 09:07:21 UTC
No you are compiling a kernel driver against glibc headers, not against kernel
headers. The author of said driver seems to have no clue whatsoever what he was
doing; for over 2 years now (as per Linus decree) the headers for the kernel are
in /lib/modules/`uname -r`/build/include

Comment 2 Bill Nottingham 2003-10-02 15:20:34 UTC
*** Bug 64641 has been marked as a duplicate of this bug. ***

Comment 3 nafiton smith 2005-04-04 20:34:36 UTC
I was installaing a fresh RedHat 7.3 on a computer with a Broadcom Ethernet 
card.
When I get the driver from HP , I see that I need to compile it. As I had not 
installed the developer tools, I had to rpm'ed the gcc. In the process, I only 
install the kernel-headers as the gcc depend on them.
When I compiled the driver source, I got the msr.h file error.
I rpm'ed the kernel-source-2.4.18-3.i386.rpm and after it was installed, the 
compilation was good.. no errors, I mean.