Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 86131

Summary: [RFE] RHEL3: CONFIG_FILTER=y in -BOOT kernel
Product: [Retired] Red Hat Linux Reporter: Matt Domsch <matt_domsch>
Component: kernelAssignee: Arjan van de Ven <arjanv>
Status: CLOSED WONTFIX QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: dale_kaisner, john_hull, tao
Target Milestone: ---Keywords: FutureFeature
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-07-15 18:54:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Matt Domsch 2003-03-14 16:55:28 UTC
Description of problem:
Dell's factory installation process uses DHCP and a PXE server, and uses 
dhclient to obtain an IP address during kickstart %post.  dhclient cannot work 
because CONFIG_FILTER=y is not set in the -BOOT kernel, and pump is not 
available in %post.

Please enable CONFIG_FILTER=y in the -BOOT kernel .config for future RHL and 
RHEL products.  This increases kernel size by roughly 1KB.

Version-Release number of selected component (if applicable):
RHLAS2.1, RHL8, Phoebe public beta 3 + special bits of rawhide

Comment 1 Larry Troan 2003-07-01 01:14:35 UTC
FROM ISSUE TRACKER...
Event posted 04-15-2003 12:03am by mdomsch with duration of 0.00        
Should probably be in the kernel bucket, assuming the Installer guys don't care
much that the kernel size will grow slightly.


Comment 2 Larry Troan 2003-07-01 01:16:46 UTC
ALSO AFFECTS TAROON...
Event posted 04-28-2003 12:59pm by mdomsch with duration of 0.00        
Not enabled in 2.4.20-2.1.27.ent -BOOT kernel (Alpha2). 

Comment 3 Arjan van de Ven 2003-07-01 08:00:07 UTC
Dell was given the choice which driver we could drop to make space for this...
Which driver did they pick ?

Comment 4 Larry Troan 2003-07-08 19:46:20 UTC
At last week's meeting Dell said we could drop any driver used uniquely by
another IHV <;-0  

Comment 5 Larry Troan 2003-07-15 18:50:51 UTC
Can we do aanything with this? If not, we need to close the issue.

Comment 6 Arjan van de Ven 2003-07-15 18:54:29 UTC
no; we're still 20kb short instead of having space to spare.