Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 86113

Summary: wvdial corruption (/usr/bin/wvdial: error while loading shared libraries: unexpected reloc type 0x05)
Product: [Retired] Red Hat Linux Reporter: Need Real Name <mc.sadler>
Component: wvdialAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0CC: mitr
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2004-09-21 14:47:13 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Need Real Name 2003-03-14 10:00:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a)
Gecko/20021207 Phoenix/0.5

Description of problem:
The command used to bring up my modem connection to the internet:
	/sbin/ifup ppp0
stopped working, and produced the following error message:
	Failed to activate ppp0 with error 8 (from man pppd ->The connect script failed
(returned a non-zero exit status))


Contents of file ppp0
	connect "/usr/bin/wvdial --remotename ppp0 --chat 'Virgin'"

Entering the command manually
	/usr/bin/wvdial --remotename ppp0 --chat 'Virgin'
produced the follwing error message
	/usr/bin/wvdial: error while loading shared libraries: unexpected reloc type 0x05

Action to solve problem
-----------------------
Erase and reinstall wvdial rpm
	rpm -e --nodeps wvdial
	rpm -i wvdial-xxxx.rpm
This fixed the problem.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce


Additional info:

Redhat 8.0 fresh installation with ext3 filesystem and prelinking enabled.
P3-733 512MB ram, 30 & 120 GB HDDs.
All rpms up2date except kernel.

Comment 1 Miloslav Trmac 2003-03-14 16:07:44 UTC
Do you use prelink?
I've had similar problems with prelink several times now.
Undoing prelinking fixed the problem, after prelinking
again this didn't occur any more (until after about a month
later...)

Comment 2 Need Real Name 2003-03-14 18:44:45 UTC
Yes, I have prelinked (with options --all --conserve-memory)

It's going to be quite hard to reproduce this one though I think.

Comment 3 Miloslav Trmac 2003-03-14 23:21:53 UTC
My guess would be as simple as:
* Prelink an executable relying on library
* Upgrade the library
Obviously this doesn't happen with all executables, but the fact
it happened to me *twice* with ghostscript indicates something.

I'll try to reproduce it on Sunday.