Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.

Bug 86100

Summary: Extremely slow installation/lockup during media check
Product: [Retired] Red Hat Linux Reporter: Kenneth Russell <kenneth.russell>
Component: installerAssignee: Michael Fulbright <msf>
Status: CLOSED DUPLICATE QA Contact: Brock Organ <borgan>
Severity: medium Docs Contact:
Priority: medium    
Version: 8.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i686   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:52:11 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Kenneth Russell 2003-03-13 22:14:13 UTC
Description of problem:

There appear to be two problems, possibly related, with the Red Hat 8.0
installer. The first is a lockup during the media check option; after scanning
the first disc the result screen fails to appear, the media is not ejectable,
and the only way to proceed is to reboot the system. This happens during every
media check on the affected system.

The second is extremely slow installation or possibly an infinite loop (have not
yet completed a successful 8.0 installation on the affected machine) in the GUI
installer. Seemingly when disc 2 is inserted, installation of RPMs becomes many
times slower than with disc 1. This is not isolated to one machine; has been
seen on at least one other machine in our lab. Installations on the lab machine
completed at an estimate of 2 hours per CD (6 hours total for the install) where
the machine reported in this bug has not yet completed a successful install of
disc 2. Currently working on the second such attempt.

Version-Release number of selected component (if applicable):

8.0

How reproducible:

Run media check on an affected machine.
Proceed with installation on an affected machine. When disc 2 is requested
installation of RPMs slows to a crawl.

Affected hardware: Thinkpad 570 notebook computer, 366 MHz Mobile Pentium II,
192 MB RAM, 30 GB hard disk. Similar installation slowdowns have been seen on
a generic 800 MHz Pentium III desktop.

Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Kenneth Russell 2003-03-13 22:40:51 UTC
Noticed on the recommendation of a co-worker that there are several messages
on virtual terminal 3:
* IOError 5 occurred copying nautilus-2.0.6-6.i386.rpm: Input/output error

That's the RPM currently failing installation. Note however that the media
has checked out on another machine, and that the last attempted install failed
on a completely different RPM, though on the same CD.


Comment 2 Kenneth Russell 2003-03-13 23:52:03 UTC
Red Hat 7.3 installs fine on the same machine. I've heard from another co-worker
that there may be bugs in the IDE driver bundled with 8.0 and that would seem
to explain the problem.


Comment 3 Michael Fulbright 2003-03-14 15:48:56 UTC
It sounds like the media is unreadable in the affected system.  I have had
numerous reports where media works on some system/CDROM combinations and not others.

If you purchased the product you should contact our customer support.


*** This bug has been marked as a duplicate of 75008 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:52:11 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.